Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

PXE E55 ProxyDHCP service did not reply to request on port 4011

Created: 12 Sep 2012 | 3 comments

Altiris® Deployment Solution™ 6.9 SP1

OS: Windows Server 2008 R2 Std

The firewall on a network isn't present.

DHCP (OES Suse Linux) option: 60=PXEClient, 66=vr-hpsim.dan.rvtk.com, 67=\PXE\Images\MenuOption131

proxyDHCP or Helper aren't used

There is such problem:

 

On the DS server in logs of PxeLog_IPFilter there are such records:

[10:22:03.851 09/13] (5056): Enter: IPFilter( ... )
  (5056)Valid port being used: 67
  (5056)Valid DHCP packet found
  (5056)Valid IP Address found: 0.0.0.0
  (5056)Valid MAC Address found: 001E0B1C7E3C
  (5056)Valid GUID found: convert to UUID: {35363134-3935-5A43-4A37-343230363346}
D [10:22:03.851 09/13] (5056): Enter: ServiceThisPacket( ... )
D [10:22:03.851 09/13] (5056): Enter: IPCheck( ... )
  (5056)IPCheck: IP on list: false.
  (5056)Allow other parsers to service this packet: true
D [10:22:40.916 09/13] (5056): Enter: IPFilter( ... )
  (5056)Valid port being used: 67
  (5056)Valid DHCP packet found
  (5056)Valid IP Address found: 0.0.0.0
  (5056)Valid MAC Address found: 001E0B1C7E3C
  (5056)Valid GUID found: convert to UUID: {35363134-3935-5A43-4A37-343230363346}
D [10:22:40.916 09/13] (5056): Enter: ServiceThisPacket( ... )
D [10:22:40.916 09/13] (5056): Enter: IPCheck( ... )
  (5056)IPCheck: IP on list: false.
  (5056)Allow other parsers to service this packet: true
D [10:23:12.474 09/13] (5056): Enter: IPFilter( ... )
  (5056)Valid port being used: 67
  (5056)Valid DHCP packet found
  (5056)Valid IP Address found: 0.0.0.0
  (5056)Checking PXEClient option length mismatch - Packet not processed.
D [10:23:49.852 09/13] (5056): Enter: IPFilter( ... )
  (5056)Valid port being used: 67
  (5056)Valid DHCP packet found
  (5056)Valid IP Address found: 0.0.0.0
  (5056)Valid MAC Address found: 001E0B1C7E3C
  (5056)Valid GUID found: convert to UUID: {35363134-3935-5A43-4A37-343230363346}
D [10:23:49.852 09/13] (5056): Enter: ServiceThisPacket( ... )
D [10:23:49.852 09/13] (5056): Enter: IPCheck( ... )
  (5056)IPCheck: IP on list: false.
  (5056)Allow other parsers to service this packet: true
D [10:24:21.270 09/13] (5056): Enter: IPFilter( ... )
  (5056)Valid port being used: 67
  (5056)Valid DHCP packet found
  (5056)Valid IP Address found: 0.0.0.0
  (5056)Valid MAC Address found: 001E0B1C7E3C
  (5056)Valid GUID found: convert to UUID: {35363134-3935-5A43-4A37-343230363346}
D [10:24:21.270 09/13] (5056): Enter: ServiceThisPacket( ... )
D [10:24:21.270 09/13] (5056): Enter: IPCheck( ... )
  (5056)IPCheck: IP on list: false.
  (5056)Allow other parsers to service this packet: true
D [10:24:33.859 09/13] (5056): Enter: IPFilter( ... )
  (5056)Valid port being used: 67
  (5056)Valid DHCP packet found
  (5056)Valid IP Address found: 0.0.0.0
  (5056)Valid MAC Address found: 001E0B1C7E3C
  (5056)Valid GUID found: convert to UUID: {35363134-3935-5A43-4A37-343230363346}
D [10:24:33.859 09/13] (5056): Enter: ServiceThisPacket( ... )
D [10:24:33.859 09/13] (5056): Enter: IPCheck( ... )
  (5056)IPCheck: IP on list: false.
  (5056)Allow other parsers to service this packet: true
D [10:24:54.840 09/13] (5056): Enter: IPFilter( ... )
  (5056)Valid port being used: 67
  (5056)Valid DHCP packet found
  (5056)Valid IP Address found: 0.0.0.0
  (5056)Valid MAC Address found: 001E0B1C7E3C
  (5056)Valid GUID found: convert to UUID: {35363134-3935-5A43-4A37-343230363346}
D [10:24:54.840 09/13] (5056): Enter: ServiceThisPacket( ... )
D [10:24:54.840 09/13] (5056): Enter: IPCheck( ... )
  (5056)IPCheck: IP on list: false.
  (5056)Allow other parsers to service this packet: true

Where to look for a solution?

Thanks!

 

Comments 3 CommentsJump to latest comment

andykn101's picture

Check firewall on server.

Try and PXE boot on same subnet as the PXE server to see if the problem is your DHCP settings or the PXE server itself.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

Indrek_K's picture

Hello Ray

I guess you are using PXE force mode because of the DHCP option 60, 66, 67.

So please check this KB http://www.symantec.com/docs/HOWTO7071 also check that you have 06  and 08 option specified.