Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Question: Ability to apply patches

Created: 15 Nov 2012 | 12 comments

Hi,

I'm using SMP 7.1 SP2 MP1. I have given access to my help desk support team to view all the patches of windows, Linux and MAC. However they can NOT right-click on patch and apply it to the client computers. if they right-click on the patch then nothing happens so access is denied. Which permission do they need for this purpose ?

Thank you

Asad

Comments 12 CommentsJump to latest comment

Robert Steinle's picture

Hi,

1. Do you want to add ability to distribute (create SWU policy) already downloaded bulletins only?

Then you'll need to enable "Distribute Software Update" privilege under Account management->Roles->'Select_role'->Privileges

2. Or to allow them to download bulletins as well?

Then you'll need to enable "Distribute Software Update" and "Download Bulletin" privileges under Account management->Roles->'Select_role'->Privileges

Regards,

Robert Steinle

Symantec Corporation

For Forum threads, please click "Mark as Solution" if answered.

Roman Vassiljev's picture

Hi Asad,

Have you created new role for your help desk support team or modified the existing one?

Please check current Software Update Management Privileges for this role(Settings > Account Management > Roles) as Robert said. Also please find section 'Right Click Menu’ under 'Privileges' tab and check if required right menu items are enabled.

In case if this does not resolve your issue, you may compare your custom permissions and privileges with Patch Management Rollout role.
Please note that Patch Management Rollout role is default role with minimal privileges for Patch Management Solution and it does not allow to stage and distribute patches until  'Distribute Software Update' and  'Download Bulletin' are enabled under section 'Software Update Management Privileges'

Thanks,
Roman

Qatar525's picture

Hi Robert and Roman,

Thank you both for your replies.

I have confirmed that help desk role has allow access for  Righ click menu, Distribute Software Update and Download Bulletin. but still has the issue. below is the the access denied picture and logs from the NS server.

Source: Altiris.Reporting.UI.ReportViewControl.OnLinkActivatedOpenWindow

Description: /Altiris/Console/Dashboard/DashboardView.aspx?ResourceGuid=XD40DC-003 (758529e2-3c9a-4737-86da-63fd2c40e595)

Source: Altiris.Reporting.UI.ReportViewControl.InitializeParameters

Description: Missing value edit controls for parameter. ParamName=_culture

Source: Altiris.Reporting.UI.ReportViewControl.InitializeParameters

Description: Missing value edit controls for parameter. ParamName=_neutralculture

Source: Altiris.Reporting.UI.ReportViewControl.InitializeParameters

Description: Missing value edit controls for parameter. ParamName=TrusteeScope

Robert Steinle's picture

Hi Asad,

It appears that they are trying to access Resource Manager page which they don't have access to. Can you describe in details steps before you see this error (from what page, what do they click, etc.)?

Regards,

Robert Steinle

Symantec Corporation

For Forum threads, please click "Mark as Solution" if answered.

Qatar525's picture

Hi Robert,

These are the steps in order

  1. click home , click patch managment
  2. click windows , software updates, bulletins and update
  3. if i right-click on the patch , it says loading and the nothing happens
  4. if i double-click on the patch then the resource manager windows pops up like the one above with access denied.

hope you get the picture now. let me know if you want more info.

thanks

Asad

Sally5432's picture

Qatar

Can the CMS Admin distribute patches?  If so, clone that role, then uncheck the things you don't want them to have access to.

I also had a lot of trouble setting up roles.  It was advised to start with a role with all privs and then remove, versus starting with an almost empty role and adding because of things going on in the back end.

---
Don't forget to mark posts as helpful if they are, and mark answers as solutions.

Qatar525's picture

Hi Sally,

thats exactly what i did , i coloned the administrator account to the helpdesk role and then removed their permission. but some where its missing the ability to have access to the patches. the logs are not friendly enough to troubleshoot.

Asad

Qatar525's picture

Hi Robert,

These are the steps in order

  1. click home , click patch managment
  2. click windows , software updates, bulletins and update
  3. if i right-click on the patch , it says loading and the nothing happens
  4. if i double-click on the patch then the resource manager windows pops up like the one above with access denied.

hope you get the picture now. let me know if you want more info.

thanks

Asad

Robert Steinle's picture

We have double-checked this locally and it appears that you'll also need "Distribute Packages" and "Download Packages" privileges, so 4 in total:

  1. "Distribute Software Update"
  2. "Download Bulletin"
  3. "Distribute Packages"
  4. "Download Packages"

You would probably want to allow "Recreate Packages" as well.

As for the double-click problem this is expected, on double-click "Resource Manager" is being opened which users from that group don't have access to.

Regards,

Robert Steinle

Symantec Corporation

For Forum threads, please click "Mark as Solution" if answered.

Qatar525's picture

Hi Robert,

Thanks for following up on the permission issue. I have verified that these 4 permission are enabled already including  "Recreate Packages".

I also checked that all the "Right-click menu" are enabled as well.

i wish the designer made the roles and permission easier frown

Asad

Robert Steinle's picture

Hi,

That's really weird. I would recommend you to try from scratch - clone new role and remove unneeded privileges and permissions. If that would not help, then you'll probably need to call Symantec support so that they would take a look directly on your environment.

Regards,

Robert Steinle

Symantec Corporation

For Forum threads, please click "Mark as Solution" if answered.