Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Question about Archiv Rule changed. Delete Mails

Created: 27 Nov 2013 • Updated: 05 Dec 2013 | 8 comments
Thomas L.'s picture
This issue has been solved. See solution.

Hello,

My question: is it possible to delete the orignal Mails after Archiving whe the Option is now first activate.

Customer has an Archiv Rule but forget to set "Delete Email after Archiv" Now he has all Mails

double in Outlook. The Orginal an the Shortcut.

I have change the Rule to "Delete" but nothing happens.

someone has an idee how to delete all Mails in Exchange that have been archived.

Thanks.

Operating Systems:

Comments 8 CommentsJump to latest comment

RahulG's picture

When the Email is archvied by EV , Ev would modify the Property of the email i.e archvied Date, SavesetId etc.

If you have the Outlok-add for EV installed you can check the Selected item property

Steps :

1. Select the one of the item which you think is archvied .

2. Press Shift + Cntrl and click on the EV icon on the outlook toolbar.

3. Click on Vault infromation and go to the selected Items property (here you can see the Detail of the fiels which are inserted by EV)

Once can then add the Column in Outlook and sort the items based on the property which enterprise vault have added and delete the Items. To get the Coulmn name you may need to use mfcmapi utilty. Will try it at my end and update you 

 

A_J's picture

Hi Thomas,

 

How many users are affected ??

Pradeep_Papnai's picture

I did same in my test lab,  Archive few items with policy setting (uncheck on 'delete original' & 'create shortcut'), as a result, there are two item (1 shortcut & 1 original).

Reverted policy setting to put check on 'delete original' & 'create shortcut', it did not touch original item as it has our hidden settings.

Started archiving again with registry 'IgnoreEVDates' value 3, now I have two shortcut (1 old & 1 new) which is pointing to same saveset id.

Details of registry http://www.symantec.com/docs/TECH76532

As far I can think of that we don't have any way to delete duplicate shortcut (or delete original who has a shortcut already in mailbox).
 

A_J's picture

Hello Thomas,

 

I would suggest to do the following..

 

First we need to delete the shortcuts from the user's Mailbox.

You can set the Delete shortcuts in folders to 0 days, check the below screenshot

shortcut deletion.png

 

Then synchronize all Mailboxes 

Do a Run Now with ShortcutProcessing selected for all Mailboxes.

The shorcuts should be deleted now.

Now apply the registry key mentioned in the article http://www.symantec.com/docs/TECH76532  --- 'IgnoreEVDates' value 3

Now you should be seeing one Shortcut in the Mailbox.

 

 

SOLUTION
A_J's picture

Just want to add a Note:

  • Delete shortcuts in folders:       Setting this makes Enterprise Vault delete old shortcuts but does not affect the corresponding archived items. Users can still search for the archived items.

    For example, you could choose to delete all shortcuts older than 12 months, but retain archived items for several years.

 

Also forgot to mention once the shortcuts are deleted please uncheck the "Delete Shortcuts in folders" and synchronize again synchronize all Mailbox.

GabeV's picture

Hello Thomas,

If you are totally sure that all the emails archived have a shorrcut and the original item is still present in the mailbox:

(1) Export the archive to PST and remove the archived items from the archive at the same time.

(2) Setup the archiving policy to remove orphaned shortcuts.

(3) Run the archiving task with 'Processing shortcuts enabled'.

(4) Confirm that all the shortcuts were removed.

(5) Verify that the archiving policy has the correct settings (create shortcut, remove original item).

(6) Synchronize the mailbox.

(7) Set the registry valut IgnoreEVDates to 3 and run the archiving task against this mailbox.

Note: the IgnoreEVDates should be created under the following location for 32 bits:

HKEY_LOCAL_MACHINE
 \SOFTWARE
  \KVS
   \Enterprise Vault
    \Agents

For 64 bits:

HKEY_LOCAL_MACHINE
 \SOFTWARE
  \Wow6432Node
   \KVS
    \Enterprise Vault
     \Agents

I hope this helps.

“Success is not final, failure is not fatal: it is the courage to continue that counts.”–Winston Churchill

A_J's picture

Hello Thomas,

 

Does the suggested steps helped ??

Thomas L.'s picture

Hello A_J

your Workaround works. Handle with care but works :-)

Thanks for Help...