Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

question about resource linking

Created: 12 Aug 2011 • Updated: 26 Aug 2011 | 7 comments
This issue has been solved. See solution.

Hello all:

My environmnt:

VCS 5.0mp3rp5 on two SUN M5000s running Solaris 10:

My question:

I have a service group set up with a disk group, network, mount points, oracle and listener resouces.

WHen I first setup the serivce group, I setup the network, disk group and mount point resouces and tested failover. failover worked fine.

However, I then added my oracle resource, linked it with the mount points, but, left the oracle resouce disbled since the DBA was not going to install oracle until the following week.

When I tested failover to the other node, the disk group and network resouces came up, but the mount points did not, they stayed offline. When I unlinked the oracle resouce from them and test failover again, they came up.

Can anybody tell me why have a link dependency from a disbled oracle resource to enabled mount point resouces, will cause the mount points to stay offline during a failover?

so,

ora_orares requires mnt_mntres

mnt_mnt1 requires dg_dgres

THe disk group comes up fine.

Thanks,

George Cebulka

********* Moved to Cluster Server Forum by MvdB **********

Comments 7 CommentsJump to latest comment

Marianne's picture

Please post section of engine_A log that contains the online attempt on node 2.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Gaurav Sangamnerkar's picture

I would also suggest to show the main.cf so as to check the config...

G

PS: If you are happy with the answer provided, please mark the post as solution. You can do so by clicking link "Mark as Solution" below the answer provided.
 

mikebounds's picture

I can't tell you why this happens, but I can tell you that it is not considered a bug.  I have worked with VCS for 10 years and have known this to happen since I can remember.  This "feature" is annoying for the reason you gave - I have been in your circumstances several times before, where as I consultant, I wanted to leave site without Oracle being installed and for the customer to install Oracle sometime later without having to do any further work with VCS.

The 2 works arounds I used were unlinking Oracle resource, so that customer had to link (maybe several mounts), enable resource and make resource Critical, when oracle was installed  as you have done and the 2nd method is:

Save config - "haconf -dump"  (with Oracle resouce created, linked and Enabled)

run "hacf -verify /etc/VRTSvcs/conf/config" (this creates main.cmd)

grep oracle_res_name /etc/VRTSvcs/conf/config/main.cmd > oracle_res_name.cmd

Now customer can just run oracle_res_name.cmd when they are ready which contains commands to create Oracle resource and link ( you can also add "haconf -makerw" to beginning and "haconf -dump -makero" to end of this file to make it easier)

Mike

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below

SOLUTION
TonyGriffiths's picture

Hi

When you say the Oracle resource is disabled, do you mean the resource was not in Enabled (Enabled=0) or something else ?

Also what was the failover trigger ?

GeorgeC's picture

I essentialy set up an oracle resouce, but, oracle was not installed. I set the resouce to enabled=0. so it would not come online and cause the resouce to fault.

As for failover, I initiated it myself via hagrp -switch <group> -to <system> command.

TonyGriffiths's picture

Are you able to provide an extract of the engine log showing when the resources (inc mount) are online on node1, then the switch to node2 ?

Personally I would have expected the Mounts to be online on the -to system, as long as they were online prior to the switch

mikebounds's picture

I agree with Tony, if you do a switch, then if Mounts were online on first system, they should online on second system if you switch to second system, but if you online the group, I would not expect the Mounts to online - you can prove this in the VCS Simulator.  One thing that would effect this is if you are using Preonline triggers - the switch will only work (online Mounts) if you use the -checkpartial option in the preonline trigger.

Mike

UK Symantec Consultant in VCS, GCO, SF, VVR, VxAT on Solaris, AIX, HP-ux, Linux & Windows

If this post has answered your question then please click on "Mark as solution" link below