Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Quick Link Dialog

Created: 19 Feb 2013 • Updated: 19 Feb 2013 | 17 comments
This issue has been solved. See solution.

When I click the links in the email I get the error below. Anyone know why? I followed the steps stated here:

http://www.symantec.com/docs/HOWTO61671

Sorry, there was error quering link data. Probably this response was already made.
Error details:
System.Web.Services.Protocols.SoapException: Server did not recognize the value of HTTP Header SOAPAction: www.symantec.com/GetLinkData. at System.Web.Services.Protocols.Soap11ServerProtocolHelper.RouteRequest() at System.Web.Services.Protocols.SoapServerProtocol.Initialize() at System.Web.Services.Protocols.ServerProtocol.SetContext(Type type, HttpContext context, HttpRequest request, HttpResponse response) at System.Web.Services.Protocols.ServerProtocolFactory.Create(Type type, HttpContext context, HttpRequest request, HttpResponse response, Boolean& abortProcessing)

Comments 17 CommentsJump to latest comment

.Brian's picture

It works fine for me.

Did you try clearing out your browser cache? Or try a different browser?

Please click the "Mark as solution" link at bottom left on the post that best answers your question. This will benefit admins looking for a solution to the same problem.

noodleNT's picture

This was the first time ever using the component so nothing should be cached. I am debugging on a Windows 7 machine though using the built in web debugger and not IIS. I haven't published it to the server yet.

What does your environment look like?

reecardo's picture

In your project properties, on the Publishing tab under General, change the URI to www.transparentlogic.com. This is what's required in the SOAPHeader right now for the Quick Link dialog.

NOTE IF YOU EVER UPGRADE TO 7.5: When 7.5 comes out, we've updated the namespace in the web reference for Quick Link dialogs to be www.symantec.com. Please be aware of that should you ever upgrade to 7.5

noodleNT's picture

Leave the Name Space name to Default and just change the URI?

reecardo's picture

Yep, just change the URI from www.symantec.com to www.transparentlogic.com. Leave the Namespace field as is. This should make Quick Link dialog links start working.

And if you ever upgrade to 7.5 when it comes out... change the URI back to www.symantec.com :)

noodleNT's picture

Same error message even though I changed it it wants to use symantec.com. I am running 7.1.1600.26:

Sorry, there was error quering link data. Probably this response was already made.
Error details:
System.Web.Services.Protocols.SoapException: Server did not recognize the value of HTTP Header SOAPAction: www.symantec.com/GetLinkData. at System.Web.Services.Protocols.Soap11ServerProtocolHelper.RouteRequest() at System.Web.Services.Protocols.SoapServerProtocol.Initialize() at System.Web.Services.Protocols.ServerProtocol.SetContext(Type type, HttpContext context, HttpRequest request, HttpResponse response) at System.Web.Services.Protocols.ServerProtocolFactory.Create(Type type, HttpContext context, HttpRequest request, HttpResponse response, Boolean& abortProcessing)

 

reecardo's picture

Could you try www.altiris.com as the URI?

I should have asked what version of the product you were on first.

reecardo's picture

Ok, some explanation to what's going on: every time the WF product got "rebranded" the Quick Links dialogs URI got forgotten. So, if you had these errors with project property www.altiris.com before, more than likely the URI that Quick Links was expecting was www.transparentlogic.com

In the 7.1 flavors if you got this error when the project property read www.symantec.com, Quick Links dialog needed www.altiris.com

When 7.5 comes out, www.symantec.com should be what's required.

So... if the original value was www.altiris.com, more than likely you need www.transparentlogic.com. To be completely sure, if you could message me a copy of your LogicBase.Components.Default DLL, I could definitively tell you what's needed. You can find it at <install>/Shared/Components

noodleNT's picture

SMACK

PM'd you the DLL

This work around does do the trick but I would rather use Quick Link Dialogs if possible.

https://www-secure.symantec.com/connect/forums/how-work-quick-link-dialog-component#comment-7829891

reecardo's picture

Just replied. Looks like you need www.symantec.com. Sorry for the runaround. Hopefully this works for you.

SOLUTION
reecardo's picture

Again, many apologies for this. I didn't think you had that updated of a build, and I assumed (foolishly :P) that it had to be an "older" value.

noodleNT's picture

After publishing the project I get the following error when one clicks the link in the email...

Sorry, there was error quering link data. Probably this response was already made.
Error details:
The request failed with HTTP status 401: Unauthorized.

reecardo's picture

What happens if you turn on looser security with the deployed project (for example, enable anonymous access)?

noodleNT's picture

In the project properties under primary service?

noodleNT's picture

That appears to have done the trick.