Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Qunatum robot and IBM drives were not auto discovered

Created: 28 Jul 2012 • Updated: 12 Sep 2012 | 8 comments
This issue has been solved. See solution.

Our environment :

NetBackup Master/Media version : 7.1.0.4

Tape library : Quantum i6k with IBM LTO5 Tape drives

OS : Windows 2008 R2 Standard edition with MPIO enabled

 

Robot and device drivers were not auto discovered in Device Manger. After a reboot, the robot and drives are visible but they get disappear after sometime.

Is MPIO feature of Windows server causing any problem for device discovery or any other reason for this problem ?

 

 

Discussion Filed Under:

Comments 8 CommentsJump to latest comment

Marianne's picture

NetBackup does not need or use MPIO. I believe Windows MPIO is for disk drives only.

NBU has its own way of dealing with multiple paths to devices. Only requirement is that you use Device Config wizard to add devices.

You need to ensure that devices are visible and usable at OS Device Manager level. Do not try to add to NBU before devices are 'stable' at OS level.
Check Event Viewer logs for clues about disappearing devices.

Please check HCL for IBM tape driver requirements.

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Taqadus Rehman's picture

One thing that i want to add in Marianne's reply that....Symantec recommends use of symantec device drives for tape drives.

Regards, Taqadus Rehman

Yasuhisa Ishikawa's picture

Symantec tape driver is no longer provided.
Check NetBackup 7.1 Device Configuration Guide page 98.
http://www.symantec.com/docs/DOC3656
----
About tape device drivers on Windows

Symantec does not provide device drivers for Windows hosts. If you require

drivers, contact Microsoft or the tape drive vendor.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

ashokk's picture

Thanks All. I agree with the fact that, unless the devices are visible at OS level, NetBackup can't see them. But have you ever faced this kind of situation ? After rebooting, devices are visible for sometime and they get disappear at a later time. We have been working on this issue since many days.  Any idea where could be the problem ? Quantum is saying there is no problem from the library end and Symantec is saying unless devices are visible at OS level, we can't help with this ? Local windows admin team is saying there is no problem at OS level.

Marianne's picture

My guess is problematic HBA.
I have see devices disappearing long ago with Emulex HBA's. O-L-D TN: http://www.symantec.com/docs/TECH33767

Have you checked Event Viewer for errors?

Manufacturer tape driver should be used. As per my previous post, see HCL for IBM tape driver requirements.

p. 142:

5. For 32-bit Windows systems, Symantec tests and recommends the use of the Symantec tape drivers with tape drives released prior to 2007. For newer drives, use the manufacturer's 32-bit tape driver. The latest release of the Symantec Tape Device Driver Installer can be downloaded from the Symantec support site. Symantec does not extensively test with the manufacturers' 32-bit tape drivers, however, they are supported, and Symantec will work with customers and vendors in an attempt to resolve any issues. Symantec and most hardware vendors listed are members of TSANet.

6. For 64-bit Windows systems, the manufacturer's most recent tape driver should be used. The Symantec tape drivers are not compatible with 64-bit Windows systems.
 
p. 159:
IBM Tape Driver Support
The latest version of the IBM tape device driver package that has been tested with NetBackup is listed below. Using the version listed here is recommended, but older versions of the tape drivers are also supported and may work well. There is no need to upgrade the tape driver if the configuration is working properly. Upgrading to the version listed here may be necessary if implementing the latest model tape drives or if problems are encountered that have been addressed by the driver provider.
If using the IBM Windows Tape Device Drivers be sure to choose the install_nonexclusive.exe executable. This option permits a tape drive to be accessed by multiple processes on a Media Server, which is a requirement for NetBackup.
NetBackup requires the IBM Data Path Failover feature to be disabled on the IBM tape device driver. To disable this feature, open the reg folder of the IBM driver package, double-click DisableDPF.reg, and reboot the system.
- IBMTape driver level 6.2.1.7 tested on Windows

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
mph999's picture

The requirement for NBU to work is that the devices are visible at the OS level - that is why Symantec is giving the answer it is.

It will probably be a SAN issue, this could include the HBA, cables, switch, gbic or any drivers / firmware involved.  Seen this issue loads of times - you should  see the devices appearing/ disappearing in the system event logs.

Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Yasuhisa Ishikawa's picture

I could not find any document stating which type of devices are supported by MPIO.

But, in this doc, it seems that mpio.sys only provide disk PDOs.
http://technet.microsoft.com/en-us/library/ee619734.aspx

If you want to get it cleared, please open a ticket to MS.

BTW, robots/tapes connected through MPXIO on Solaris is also unstable. MPXIO does not support tape devices - it is clearly documented in some Sun's document.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

Mark_Solutions's picture

Please check your SAN zoning to see if any other servers have access to the tape drives that could be causing issues.

If they dissapear from the system then it usually indicates and interrupt somewhere causing a break in connection and although they are fibre connected it can still require a reboot of the Media Server to re-attach them correctly.

Always use the latest drivers from the manufacturers site - if it is a Quantum library then they should be either IBM or HP drives so it is relatively straight forward to get the drives (as pointed out Symantec do not provide 64 bit drivers)

Also keep the HBA drivers up to date

Check the Media Servers appliaction and event logs for clues (Plug and Play or anything relating to the tape or HBA driver.

Also take a look on the library web GUI - look under Setup - Drive Setings to see what the topology of the drives it and their speed to make sure that they are detecting the fibre correctly.

Finally, to stop Windows interferring with the drives ensure that the Removable Storage Service (if installed - it is an option on 2008) is stopped and disabled and that the Tape Unit Ready registry key has been applied (this does apply to all Windows versions - see this tech note: http://support.microsoft.com/kb/842411)

Hope these pointers help

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.