Video Screencast Help

Ralus backslash and hostname in file path causing 0xe00084af dir not found error

Created: 03 Apr 2013 | 5 comments

Hi-

I have two Ralus agents where one backs up remote selections just fine and the other fails with directory not found because the dir being told to open has the hostname and a backslash in the path!!!  How can get the Windows media server to STOP putting the hostname in the path for selections.

I've turned up logging on bermote and here is the relevant problem -- on the machine that fails:

 

b29feb40 Wed Apr  3 11:04:00 2013 :             vx_stat_by_name: Getting stat of /bin
b29feb40 Wed Apr  3 11:04:00 2013 : ====> VX_FindNext
b29feb40 Wed Apr  3 11:04:00 2013 :             vx_stat_by_name: Getting stat of /etc
b29feb40 Wed Apr  3 11:04:00 2013 : ====> VX_FindNext
b29feb40 Wed Apr  3 11:04:00 2013 :             vx_stat_by_name: Getting stat of /sbin
b29feb40 Wed Apr  3 11:04:00 2013 : ====> VX_FindNext
b29feb40 Wed Apr  3 11:04:00 2013 :     VX_FindNextFile: FS_NO_MORE, dir list is empty
b29feb40 Wed Apr  3 11:04:00 2013 :     FindObject: FindFirstFile or NextFile returned error : 2000FE07'
b29feb40 Wed Apr  3 11:04:00 2013 :     FindObject: returning 2000FE07
b29feb40 Wed Apr  3 11:04:00 2013 : ====> VX_FindClose
b29feb40 Wed Apr  3 11:04:00 2013 : ====> VX_CloseDir
b29feb40 Wed Apr  3 11:04:00 2013 : ====> VX_ChangeDir
b29feb40 Wed Apr  3 11:04:00 2013 : ====> VXX_ChangeDir : apath : \soekris-6501.magnemotion.local\[ROOT], asize : 47
b29feb40 Wed Apr  3 11:04:00 2013 : ====>ChangeDir : psize : 47
b29feb40 Wed Apr  3 11:04:00 2013 :             vx_stat_by_name: Getting stat of /\soekris-6501.magnemotion.local\[ROOT]/var/www
b29feb40 Wed Apr  3 11:04:00 2013 : Function vfmStatFileName, VxMS resolved the error code to this message:  object not claimed by any plugin
b29feb40 Wed Apr  3 11:04:00 2013 :             vx_stat: objname is /\soekris-6501.magnemotion.local\[ROOT]/var/www returned 2059
b29feb40 Wed Apr  3 11:04:00 2013 :             vx_open_by_name: Opening object name : /\soekris-6501.magnemotion.local\[ROOT]/var/www, openflags : B
b29feb40 Wed Apr  3 11:04:00 2013 : Function vfmOpenFileName, VxMS resolved the error code to this message:  object not claimed by any plugin
b29feb40 Wed Apr  3 11:04:00 2013 :             vx_open_by_name: Error : 2059
b29feb40 Wed Apr  3 11:04:00 2013 :             vx_open_by_name: new handle =(
b29feb40 Wed Apr  3 11:04:00 2013 :     VX_FindFirstFile: vx_open_by_name failed for path '/\soekris-6501.magnemotion.local\[ROOT]/var/www' errno=-536836984
b29feb40 Wed Apr  3 11:04:00 2013 : TF xfer time = 0 seconds.
b29feb40 Wed Apr  3 11:04:00 2013 : WRITE:  tpreceive_fail_count = 1
b29feb40 Wed Apr  3 11:04:00 2013 : WRITE:  waiting_on_buffers_count = 0
b29feb40 Wed Apr  3 11:04:00 2013 : WRITE:  buffers_written_count = 1
b29feb40 Wed Apr  3 11:04:01 2013 : TF_CloseSet()
b29feb40 Wed Apr  3 11:04:01 2013 : FreeFormatEnv( cur_fmt=0 )
b29feb40 Wed Apr  3 11:04:01 2013 : Detach from: \\soekris-6501.magnemotion.local\[ROOT]
b29feb40 Wed Apr  3 11:04:01 2013 : Resetting hard link info
b29feb40 Wed Apr  3 11:04:01 2013 : Hard link info has been reset
b31ffb40 Wed Apr  3 11:04:01 2013 : ProcessRequest: thread exiting
b29feb40 Wed Apr  3 11:04:03 2013 : TF_FreeDriveContext( B3C21580 )
b29feb40 Wed Apr  3 11:04:03 2013 : TF_FreeTapeBuffers: from 10 to 0 buffers
b29feb40 Wed Apr  3 11:04:03 2013 : Backup Job Stop(0)  - Wed Apr  3 11:04:03 2013
b29feb40 Wed Apr  3 11:04:03 2013 : VX_RemoveDLE: DestroyDLE()
b29feb40 Wed Apr  3 11:04:03 2013 : VX_RemoveDLE: DestroyDLE()
b29feb40 Wed Apr  3 11:04:03 2013 : VX_RemoveDLE: DestroyDLE()
b29feb40 Wed Apr  3 11:04:03 2013 : FreeFormatEnv( cur_fmt=0 )
b29feb40 Wed Apr  3 11:04:03 2013 : FreeFormatEnv( cur_fmt=0 )
b29feb40 Wed Apr  3 11:04:03 2013 : FreeFormatEnv( cur_fmt=0 )
 
 
On the machine that works:
 
 
b31ffb70 Wed Apr  3 10:41:20 2013 :             vx_stat_by_name: Getting stat of /mnt
b31ffb70 Wed Apr  3 10:41:20 2013 : ====> VX_FindNext
b31ffb70 Wed Apr  3 10:41:20 2013 :             vx_stat_by_name: Getting stat of /lost+found
b31ffb70 Wed Apr  3 10:41:20 2013 : ====> VX_FindNext
b31ffb70 Wed Apr  3 10:41:20 2013 :             vx_stat_by_name: Getting stat of /media
b31ffb70 Wed Apr  3 10:41:20 2013 :             vx_stat_by_name: Dir </media> cannot be read or is an excluded filesystem type
b31ffb70 Wed Apr  3 10:41:20 2013 :     SkipObject: f_type is 0, returning TRUE
b31ffb70 Wed Apr  3 10:41:20 2013 :             vx_stat_by_name: Getting stat of /srv
b31ffb70 Wed Apr  3 10:41:20 2013 : ====> VX_FindNext
b31ffb70 Wed Apr  3 10:41:20 2013 :     VX_FindNextFile: FS_NO_MORE, dir list is empty
b31ffb70 Wed Apr  3 10:41:20 2013 :     FindObject: FindFirstFile or NextFile returned error : 2000FE07'
b31ffb70 Wed Apr  3 10:41:20 2013 :     FindObject: returning 2000FE07
b31ffb70 Wed Apr  3 10:41:20 2013 : ====> VX_FindClose
b31ffb70 Wed Apr  3 10:41:20 2013 : ====> VX_CloseDir
b31ffb70 Wed Apr  3 10:41:20 2013 : ====> VX_ChangeDir
b31ffb70 Wed Apr  3 10:41:20 2013 : ====> VXX_ChangeDir : apath : opt, asize : 4
b31ffb70 Wed Apr  3 10:41:20 2013 : ====>ChangeDir : psize : 4
b31ffb70 Wed Apr  3 10:41:20 2013 :             vx_stat_by_name: Getting stat of /opt
b31ffb70 Wed Apr  3 10:41:20 2013 :             vx_open_by_name: Opening object name : /opt, openflags : B
b31ffb70 Wed Apr  3 10:41:20 2013 :             vx_open_by_name: new handle =0xb2818468
b31ffb70 Wed Apr  3 10:41:20 2013 :             vx_stat_by_name: Getting stat of /opt/ccollab_server
b31ffb70 Wed Apr  3 10:41:20 2013 : ====> VX_CloseDir
b31ffb70 Wed Apr  3 10:41:20 2013 : VX_SetupWorkPath: dss_cur_dir is not valid
b31ffb70 Wed Apr  3 10:41:20 2013 : VX_SetupWorkPath: req size is 170
b31ffb70 Wed Apr  3 10:41:20 2013 : VX_SetupWorkPath: req size after strsize(sname) is 170
b31ffb70 Wed Apr  3 10:41:20 2013 : VX_SetupWorkPath: path is /. copying cur dir and sname
b31ffb70 Wed Apr  3 10:41:20 2013 : VX_SetupWorkPath: path with cur dir is /opt
b31ffb70 Wed Apr  3 10:41:20 2013 :             vx_stat_by_name: Getting stat of /opt
b31ffb70 Wed Apr  3 10:41:20 2013 : ====> VX_FindFirst
b31ffb70 Wed Apr  3 10:41:20 2013 : last_slash called with non absolute path name '*.*'
 

 

On the above setup, it's getting stat for /opt without the hostname garbage and on the first one it's adding the hostname and backslash and causing normal unix directory stat to fail.

How on earth do I get the media server or whatever to STOP putting the hostname and backslash in there?

I've tried re-creating the selection list w/ the remote unix/linux servers to no avail.  In the raw info in the selection list the selections are the same, just two different linux boxes where one insists on having the hostname in the path names...  

The ralus versions on each host:

 

 

[root@soekris-6501 VRTSralus]# cat ralus.ver 
ralus=2896.9
mdm=MDM_v0.0.4284.1
vxms=VxMS_v4.4-035
 

[root@mmi-storage ~]# cat /var/VRTSralus/ralus.ver 

ralus=2896.9
mdm=MDM_v0.0.4284.1
vxms=VxMS_v4.4-035
 
The media server is a Windows server 2003 setup with Backupexec 2010r3 running.
 
Operating Systems:
Discussion Filed Under:

Comments 5 CommentsJump to latest comment

malk315's picture

I upgraded my Windows Server to 2010 R3 and the Ralus agents to 5204.4 and the problem persists!!!

Isn't there someone from Symantec / Veritas who can look at the above log and have a CLUE as to why on one of my linux boxes it puts the ridiculous UNC path in there which is what totally makes the underlying linux stat() system call on the path fail.  This is because Linux need a path like this:

/var/www

NOT LIKE THIS RIDICULOUS THING:

/\soekris-6501.magnemotion.local\[ROOT]/var/www

All that needs to happen is for either the linux agent to strip off the stuff up through [ROOT] or the windows server needs to do that.  There's got to be something very trivial wrong here...

 

pkh's picture

I would suggest that you open a support case with Symantec for them to look at this problem.  Before doing so, make sure that the version of Linux/Unix that you are using is supported.  See the SCL below

BE 2010|2010 R2|2010 R3 Software (SCL)

flo@she's picture

Hello malk315,

did you find any solution for your problem. I have the same problems.

dsilcock's picture

Hi flo@she, did you find a solution to this problem?

I noted that our backups started failing at the same time because of this problem (they were previously fine).

I was away from the office for a week and assumed that someone had updated a piece of software out of compatible range while I was gone and wondered if you had any insight?

malk315's picture

Hi Evreyone-

I have NOT found a solution for this and it is so annoying because it is a REAL PROBLEM and Symantec wont do anything about it.  I opened a support case but our support contract expired -- we have given them enough money already and I'm not giving them a dime more for software that is garbage in my opinion.  Really symantec?  Theres is NO ONE who actually works on the software that can strip out the backslash garbage in the path so it resolves to an ACTUAL PATH on the machine?  It is such a BLATENT issue and multiple people have the problem, yet you plug your ears and dont do anything while people still pay for this lame excuse for software...

Right now we are working towards abandoning BackupExec.  The main reason we have it is for backing up an exchange server, but now that microsoft's latest office doesnt support Server2003 exchange server, we are switching to offsite office365 type e-mail for our company and thus no more need to backup an exchange database.  Since all of our fileservers are linux, I can use the vast array of opensource tools on linux and connect up our 16 cartridge LTO tape autoloader to one of our linux servers and then rsync disk to disk followed by dump to tape for an excellent backup solution.  Symantec don't let the door hit you one the way out.

Good luck to those of you suffering from the same problem.  I hope you get the support you need...  I know I didn't.