Video Screencast Help

RALUS w/ Backup Exec 2010 issue

Created: 15 Sep 2010 • Updated: 18 Oct 2010 | 13 comments
This issue has been solved. See solution.

I just upgraded to Backup Exec 2010 and all went well except for the RALUS agent.  The installation of the agent went great and I was able to select the directories I wanted and the subsequent backup worked.  The trouble started when I tried to go back into the selection list and uncheck some directories.  When I expand the host name I then get [ROOT] and when I try to expand that the plus sign just disappears and nothing is displayed.  I first started restarting things and that didn't work.  I then got rid of the password requirement for the beoper group, this did nothing.  Lastly I reinstalled the agent and I am still having the same issue.  Funny thing is when the nightly backup job run it backs up the data that I select when I first went in.  I can also see the text version of the selections when I go into View Selection Details, but if I try and edit them the path is shorted because backup exec can't actively see the directories.  I installed RALUS on a Snap server the same day and that server's agent is working fine.  Not sure what to do at this point.  I attached a picture of the selection list.  Thanks

Comments 13 CommentsJump to latest comment

ailsharad's picture

Hi Kurt Hicklin,

this seems to be some issue with the publishing of that linux server to the media server .if this would have been a issue with the agent then your backup also might have failed with error "could not connect to remote agent" .

kindly add the IP address of your Linux server to "user defined selection" and the try to expand the same and let us know the results .

Thanks & Regards

Sharad Ail

RahulG's picture

When you connect to the linux server make sure you use an account which have proper permission on the linux box i.e should be root or member of BEoper group ..So when you expand the linux server in the selection ,right click on the lInbux box in the selection and select connect as ..

This an issue usually caused because of  permissions

Chris Riley's picture

What happens if you create a new selection list? Do you still have the same problem?

Also, what flavour/version of Linux/Unix are you running on this server?

Kurt H's picture

I added the IP address to the user defined selections and got the same results.

The beoper group is present and root is a member.  When I connect I do get the login credetial screen and I've had the same root login there for a long time that I've used so I know it's connecting as root.  I've right clicked and done the connect as a bunch of times, selecting the root login and always the same issue.

If I open a new backup job and start with a new selection list I have the same issue.  We're running Red Hat Enterprise 5 on the server I'm having trouble with.

Thanks

 

 

VJware's picture

Check if the firewall & SELINUX is disabled...

Kurt H's picture

Let me first say that I'm not a Linux expert by any means.  As far as the firewall is concerned it appears to be on as best I can tell through webmin.  I'm not sure what is any changes were made to the firewall, meaning it may just be default settings.  SELINUX is disabled.

Another thing I might mention is that I upgraded from 11D and I was running the legacy Backup Exec 8.x/9.x agent previously.  This agent didn't have this problem.  I of course disabled the legacy agent before the upgrade as well.

Kunal.Mudliyar's picture

Hi Kurt,

Please try this

1. Uninstall the Ralus agent using the ./uninstallralus switch from the installation directory

2. Navigate to the selection list > View selection details , make a note of the

text selections for the Linux Box(UV3) and then delete them.

3. Restart the Backup exec services from the Media server. ( Tools > Backupexec Services > Restart services)

4. Install the Ralus agent again using the ./install switch

5. Restart the Ralus services using the /etc/init.d/VRTSralus.init switch.

6. Try to naviate to the selections.

Hope this helps.

Ref :http://seer.entsupport.symantec.com/docs/282010.htm
 

Technical Support

Symantec

VJware's picture

Try the following:
Stop the RALUS using the following command
/opt/VRTSralus/bin/VRTSralus.init stop

Browse to the directory /opt/VRTSralus/bin
Type  ./beremote --log-console

Post the output (ensure you are using the root account )

Kurt H's picture

I reinstalled and removed the items from the selection list and I'm still having the issue.

 

I attached a file of the output.

AttachmentSize
logfile.txt 7.07 KB
VJware's picture

Seems an issue with the filesystems...unmounting them could probably make BE see the file systems & accordingly allow you to expand the ROOT selection...

SOLUTION
Kurt H's picture

I'll try that tonight and see if that makes a difference.

Kunal.Mudliyar's picture

Try creating a new account in Linux, name it BE, and add it to the BEoper group

Create a logon account in the Backup exec with the name BE and the same password u chose for the Linux account

Restart the Ralus as well as the Backup exec services.

Hope this helps

Technical Support

Symantec

Kurt H's picture

Unmounting the file system worked, although when I first tryed to connect I got an error that the server may not be running the agent even though it was running.  After restarted the agent again I was able to see the file stucture.  Hopefully this isn't an ongoing problem.  Thanks to everyone for the help!