Video Screencast Help

random tape selection on Backup Exec 2010

Created: 24 Jun 2013 • Updated: 24 Jun 2013 | 7 comments

Hello,

As I could not find a solution via the search option, I try it this way, now. Hoping anybody can help me!

We are using Backup Exec 2010 R3 on a Windows 2008 R2 Server with two different Tape Libraries in 2 Locations (Dell PV124t and Dell TL2000)

The Backup Jobs are created as follows:

  • Differential Backups on a daily basis, Monday to Thursday (Backup on Tape)
  • Full Backups on a weekly basis, at the weekend (Backup on Tape)
  • VM Backups on a monthly basis, last weekend of month (Backup to Disc, then copied to tape)

We also created Backupsets for the four different  kind of Jobs:

  • Daily Diff Backup on Tape
  • Weekly Full Backup on Tape
  • Monthly VM Backup to Disc
  • Monthly VM Backup on Tape

Tapes for Full and VM Backup are changed after the backup jobs are completed each week and the newly inserted tapes get deleted before the next backup will run. So they are definitely empty and overwritable.

The Tapes in the Library have dedicated slots for each type of backup:

  • tapes in Slot 1,2,3 are assigned to weekly Full Backup Set
  • tapes in Slot 4,5,6 to monthly VM Backup Set
  • tapes in Slot 7,8,9 to daily Diff Backup Set

Since some weeks, we keep experiencing problems with the selection of the Tapes. For Example, last weekend the full backup was written on a tape in slot 1 (which is correct) and slot 7 (which was planned for differential backup). Tapes in Slot 2 and 3 were still empty. It’s the same on the other library which is managed by the same Backup Exec 2010 Server.

Anybody there, having an idea, what this is caused by?

Operating Systems:

Comments 7 CommentsJump to latest comment

CraigV's picture

Hi,

 

Unless you've partitioned your libraries, you need to rely on your OPP/Append settings...in which case any tape that is available will be used by a backup job. This is probably what you're getting.

In order to dedicate specific tapes to specific jobs (and to know this is going to stay this way), you need to partition your tape library according to your slot breakdown above, and retarget the jobs to them.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

PBMS Admin's picture

Craig, thanks for the quick reply. But what do you mean with partitioning the tape library. I thought, with the backupsets we assigned the jobs to dedicated tapes already. Can you please explain how to do it?

CraigV's picture

Hi,

 

Your tapes might be dedicated to a specific media set. However, they all get returned to the Scratch set once they become overwritable...normally not an issue, unless you want specific tapes to be used ONLY by specific jobs.

Follow the TN below to partition a library:

http://www.symantec.com/business/support/index?pag...

You need to go to your jobs and then just redirect them to the relevant partition. Also then make sure the tapes used by these jobs are inserted into the correct partition.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

pkh's picture

Your problem is due to the fact that there is insufficient ovewritable tapes in your targeted media set.  BE will grab overwritable tapes from other media sets to prevent the job from failing.  See this document

How Backup Exec searches for overwritable media

What you need to do is to either put more tapes into the media sets or change your OPP such that there is sufficient overwritable tapes BEFORE the start of the jobs.  See this document for a better understanding of OPP/AP

OPP and AP explanation

If you do not fix your existing problem of insufficient overwritable tapes and proceed to partition your library, your jobs will fail when they cannot find sufficient overwritable tapes in the targeted partition.  BE will not be able to use an overwritable tape from another partition.

PBMS Admin's picture

Why are there insufficient overwriteable tape, when I deleted all new tapes after I changed them, and assigned them to the dedicated Backupset after deletion. i know they will be assigned to temporary media after deletion but I assign them myself after deletion. They are still overwritable and empty on monday, after the backup ran on other tapes at the weekend!

pkh's picture

By deletion, I take it to mean erase.  When you erase a tape, it is assigned to the scratch media set.  If you then associate them with a media set then it will take the OPP of the media set and the tapes will not be overwritable.  You should leave them in the scratch media set wthere they are ovewritable.  You can check this yourself by erasing a tape and then move it a media set.  In the media tab, click on the tape and check the Protected Until column.

PBMS Admin's picture

Thanks, that's what I did'nt know about. For the VM Backups it seems to be the solution. I changed the retention period from 4 to 3 weeks and will see what will happen at the weekend. Thanks a lot for now pkh