Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

RAW disks

Created: 29 Aug 2013 • Updated: 29 Aug 2013 | 5 comments

Hello, My backup include vmdk backups of VMware. I can only select the vmdk file when I browse trough the tree to make a selection. GRT is diabled. Some VMs have RAW disk mappings. No problem for me because these aren't backup. My problem is that my job resturns the status failed and tells me about this RAW disk mapping not being backed up: "Error : e0009599 - The virtual machine has physical disk(s). The disk marked physical RDM will not be backed up."

I know it is not being backed up! I don't want my job failed. How to prevent this?

Thank you.

Operating Systems:

Comments 5 CommentsJump to latest comment

Jaydeep S's picture

Note: Symantec does not support excluding RDM or independent disks from the backup of a virtual machine

Not sure what version of Backup Exec are you using. If this is BE 2010 the you could exclude the disk and perform the backup

http://www.symantec.com/docs/TECH124365

If it is BE 2012, the exclusion option is removed as the resulting backup is not supported and could result in a restored machine that cannot function as one or disks were excluded.

The supported solution is to run a backup of the VM as a physical backup using the Remote Agent. 

VJware's picture

Best way to remove the error would be to backup the VM as a physical machine i.e. backup using the Remote Agent.

Another method (if using BE 2010) would be to exclude the RDM disk from the backup selections. However, this is not recommended as there can potentially be a problem during restore.

http://www.symantec.com/business/support/index?pag...

Apart, from these options, there is no way to prevent the error message as it is expected when a snapshot of the RDM disk is attempted.

bastwin's picture

Thanks for your fast answers. Almost all of my servers are virtual. I perform file backups using Backup Exec where needed. Backup a VM as it is a physical machine makes no sense to me because the vmdk backup I use to restore the whole machine. Backup Exec cannot be used to restore the whole machine. Before I backed up vmdk successfully and restored them when needed. In these days we used iscsi initiator to map to LUNs on the SAN. The iscsi connection was setup within the VM itself. Now we changed this and the iscsi connection is created on the ESX server and the disk is added as RAW disk in the VM settings. Exclusion is my solution! I didn't noticed this button before. I tested it but still get this error message. I added a attachment so you can see how I did it. Anyone know what's wrong with my exclusion? Maybe this workaround doesn't work for RAW mappings?

AttachmentSize
RAW backup troubleshooting.docx 103.54 KB
VJware's picture

Per the screenshot, there seems to be a difference in the name of the VMDK. The exclusion has (Independent) whereas the original VMDK does not have this.

bastwin's picture

Yes VJware because harddisk 1 is the one that I want to be backed up (and it is working but i got this failure message as if the backup is failed). This name looks like the same as Harddisk 2 somehow. Harddisk 2 is the one that I want to exclude. In the example of Symantec you see different filenames for the vmdk's. I see I forgot to add one more screenshot. Here it is attached.

Capture.PNG