Video Screencast Help

RD1000 disk cartridges, eject problem

Created: 05 Feb 2008 • Updated: 21 May 2010 | 17 comments
Hi!,
 
I have an internal Dell RD1000 with disk cartridges. The problem is that automatic eject of the cartridges when a job completes does not work. Eject from the devices tab in Backup Exec works fine. 
Is it a known bug?
 
 
/T
 

 

Comments 17 CommentsJump to latest comment

SOBO's picture
I have this same problem with the RD1000.  I posted in the General discussion forum last night.
 
Would there be a reason that the tape will not auto eject after a scheduled job completes?  I have setup a daily full backup and checked the box to have the tape auto eject after job completes.  I am using Backup Exec 11d.  I can manually remove the tape by going through Backup Exec.  The hardware is a single tape drive, a Dell RD1000.  We have a two tape rotation.

The owner wants the full backup to run at midnight and then come in the next morning and be able to remove the tape and put in the second tape for the next night's backup.  Would I need to setup a scheduled job to inventory the tape before the next night's backup begins??


Thanks for any help!
Sobo
SOBO's picture
I did a google search and found this posting from June '07 in this forum:
 
RD1000's don't (in my experience) work that well with BESR.  BESR's service "locks" the drive, and you cannot "eject" a cartridge while the BESR service is running.  Stopping the service permits ejection.
 
This is a HUGE problem for anyone wanting to run BESR and have offsite bare-metal capable recovery points in convenient form.
 
I have spent all day on the phone today with Dell's Enterprise support (PowerEdge 2900 server, with Dell-shipped RD1000 drive and BESR 7.0 SBS Edition) and no one has been able to give any answers. 
 
As far as I'm concerned, BESR is VERY problematic with RD1000's and fails our initial compatibility testing.
 
Someone over at SYMC needs to get one of these drives in and test with it--especially when you're dealing with rotations which require cartridge swap and removals.
 
 
Has any resolution come of this?  I figure a script could run to net stop and net start the service to release the tape.
colinski's picture

Hi

Any luck with finding a solution?  I am going to try a net stop and net start routine during the night and see if this unlocks the tape so that it can be unlocked by pressing the button on the drive.

Currently we eject the tape by going into windows explorer and right click on the drive and click eject however our client has to do this which is very inconvenient.

I suspect that some kind of windows script must be able to do this automatically?

Thanks

Colinski! :manwink:

SOBO's picture

I havent found anything.  Was hoping Symantec would have some insight into this, but havent received any replies until you.  Im not one to write scripts but have a guy I work with that is helping me get one to eject the drive.  And schedule a task.  If that doesnt work, we are going the online backup route.  I will post the script for you if it works for me.

Sobo

Elarson29's picture
GRT(Granular Restore Technology) does not work with removable backup to disk storage devices. Whether it is the Dell RD1000 or Tandberg's RDX, it will not work as one might expect. Backup Exec also cannot eject the RD1000 cartridge. The RD1000 is used as a Removable Backup to Disk Folder, you cannot eject a folder. You can install the utility for the RD1000 from the CD that came with the unit from Dell.
 
The following article contains information and other links to further information about GRT and RB2D
 
415Skool's picture
I just ran a backup job to RD1000 w/ eject option and it worked.  This is on a brand new Dell PE 2950 running Win2K3 R2 32bit with all the latest updates.  RD1000 util installed.  BE11d w/ all updates.  Job is setup as B2D, just a simple full disk backup (drives, sys state, shadow copy).  No fancy agents or options licensed.  Firmware on RD1000 is Dell's latest at 0036.



Message Edited by 415Skool on 03-13-2008 10:03 AM

Message Edited by 415Skool on 03-13-2008 10:04 AM

R H 2's picture

If you are running Backup Exec System Recovery (BESR) prior to 7.02, that might be causing the problem.  See the release notes for 7.02

http://seer.entsupport.symantec.com/docs/293312.htm

acetcetera's picture

I have the RD1000 with Backup Exec 12 (with all the latest patches) installed at two different client sites both running on Windows Server 2003 machines. One site is working perfectly well, while the other site is having issues with ejecting the removable disk.

Reading this post I noticed the workaround to stop the RDXmon services then eject. Interestingly enough, on the client site that does work the service is listed as RDXmon 1.12, while the non-working site's service is listed as RDXmon 1.16 (I had downloaded the latest drivers from Dell on the non-working site and used the install disk that came with the unit on the working site).

I have since uninstalled the newer version of the RDX utilities and installed the older 1.12 version on the non-working site. This seems to have resolved the issue as far as initial testing goes (ran a backup job and was able to eject the drive by pressing the button).

Hope this helps and good luck!

R H 2's picture

If you don't mind, let us know in a week or so if that is still working out for you.  And I'd like to hear back from anyone else who tries this and what your result is.

Thanks a lot for sharing!

thanatos8877's picture
We were having this same problem at a client's site.  I found this forum while attempting to find an answer.  I finally decided to try my hand a writing a script that would handle this.  We had found that stopping the "RDXMon" service allowed the drive to be ejected.
 
This script will stop the server "RDXMon", eject the drive (Drive letter MUST be specified in the script...change it to suit your needs), and then restart the service.  Using this as a "Post-command" after the backup completes has fixed our issue...the backup completes and ejects the drive consistently.  I used a batch file to call up the VBS script.
 
I hope this helps some of you!
 
Code:
'+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++' VBScript:          AUTHOR: B.Spivey (thanatos8877 @ hotmail.com)'' SCRIPT NAME:       EjectRemovableMedia.vbs'' REVISION DATE:     5/28/2008'' PURPOSE:           Eject removable media'' COMMENTS:          The removable hard drive RD-1000 fails to eject properly'                    after Symantec Backup Exec is finished backing up.'+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++Option ExplicitOn Error Resume NextWscript.Timeout = 3600 'Number of seconds before script times out'Declare the variablesDim strComputer, strServiceName, strDriveLetterDim objWMI, objServiceDim dDim WshShellDim strCommand'Set the String ConstantsstrComputer = "."strServiceName = "RDXMon" 'RDXMon is the service that controls the Dell RD-1000.strDriveLetter = "E:\" 'Please change the drive to suit your needs'Use WMI to stop the service listed in the String Constantsset objWMI = GetObject("winmgmts:\\" & strComputer & "\root\cimv2")set objService = objWMI.Get("Win32_Service.Name='" & strServiceName & "'")objService.StopService'Sleep - the sleep function is in milliseconds (add 3 0's to your desired number of seconds)Wscript.Sleep(5000)'Use FSO to eject the drive listed in the String ConstantsFor Each d in CreateObject("Scripting.FileSystemObject").Drives    Eject strDriveLetterNext'Sleep - the sleep function is in milliseconds (add 3 0's to your desired number of seconds)Wscript.Sleep(5000)'Use WMI to start the service listed in the String Constantsset objWMI = GetObject("winmgmts:\\" & strComputer & "\root\cimv2")set objService = objWMI.Get("Win32_Service.Name='" & strServiceName & "'")objService.StartService Sub Eject(DRIVE)   Dim ssfDrives    ssfDrives = 17   CreateObject("Shell.Application")_  .Namespace(ssfDrives).ParseName(DRIVE).InvokeVerb("E&ject") End Sub


 

 
 



Message Edited by thanatos8877 on 06-05-2008 07:48 AM

kmillican's picture

Is anyone continuing to have issues with the RD1000, and BUE 12 with auto eject after a job?

ridergroov1's picture

Yes i'm stilling having this issue.  On the phone with Symantec right now...AGAIN.  They have not been able to solve this for me yet.  Very frustrated.  If anyone has any good info regarding a fix for this problem I would greatly appreciate it.  Thanks.

R H 2's picture

Is your problem that is doesn't eject at the end of the job or that it will not eject when you push the button?

kmillican's picture

What i have found is that you have to use the rdxmon utility, and you cant use the grt option and then the eject after job option will work.

ridergroov123's picture

HI folks. Right, I can't eject with the button or within the OS after the Backup job runs.  I spoke to Dell about it today and they said removing GRT from the backup exec job will do the trick.  Haven't gotten the chance to try it yet though.

AMEULI's picture

As you can tell now in 2008 this is not a hot thread.  I can say this.

 

Latest Dell Drivers + built in utility & BE 12 - ZERO PROBLEMS.   <- notice the Period

ComtecNY's picture

What I have found is that if I stop and restart the RDXmon, I am still not able to eject the drive. If I stop  the Backup Exec services, I am not able to to eject the drive. If I restart the Backup Exec services, the drive is allowed to eject. The Exchange Granually Recovery feature may be an issue and I am testing that out over the next couple of days. 

 

I also creates a simple script and scheduled it to run every morning to restart the backup exec services in order to release whatever isstopping the eject from working.

 

REM - Stop Backup Exec services.

C:

cd \

cd  "\Program Files\Symantec\Backup Exec\"

"C:\Program Files\Symantec\Backup Exec\bemcmd" -o503

REM - Start Backup Exec Services.

"C:\Program Files\Symantec\Backup Exec\bemcmd" -o502

 

This is Backup Exec 12 and RDXmon 1.16.