Video Screencast Help

Re-install Backup Exec 10D on same server

Created: 04 Dec 2013 | 4 comments

This is a similar post to a request regarding B. Exec 2010.

However, this relates to Backup Exec 10D.

I am working with a server that is running short on space on the C:\ drive. (10GB drive)

I would like to uninstall Backup Exec 10D from C:\  and reinstall on the D:\ drive on the same server. (This will save me about 500 MB and buy me enough time to build a new Server with a bigger drive)

I think I only have 2 questions.

1) What files do I need to save from original install and how do i import them to the new install so the jobs and catalogs are recognized by new installation?

2) Is SQL Express automatically uninstalled as part of the B. Exex uninstall? And can I install SQL Express on D:\  ?

 

Anything else I need to consider?

 

Operating Systems:

Comments 4 CommentsJump to latest comment

lmosla's picture

Run all of your Live Updates first. Then stop the BE services along with the SQL Server (BKUPEXEC) service, make a copy of your Data and catalog folders from the installation directory then uninstall Backup Exec.
After it is reinstalled to the new path stop the same services as before, copy these over the Data and Catalog folders, start the services and then run all of your updates to get everything to the same patch level as before  see if this document helps:  http://www.symantec.com/docs/TECH62744 

JustTryinToGetItToWork's picture

Ok.

I have done as instructed on a test server ( in a virtual machine just in case it didnt work) and I have zero joy (except for fact that it is Friday)

Upon completion of install of 10D and copying Data and Catalogs into the default location, I have no job history nor no jobs in 'job setup' or any history of any kind.

Interestingly, when I copied the files into the 'Data" folder , i got an error that 3 files couldn't be copied. The three files were:

1.     BEdb_dat.mdf

2.     BEdb_log.ldf

3.     msqq000000000.dat

I did use Beutil.exe and went into media servers...added my server by giving it a generic name and then chose the option to "copy database".  This then prompted me to the location of #1. BEdb_dat.mdf and #2. BEdb_log.ldf

However, it did not complete the process without error. Error I received was:

Error: Failed Registry Read on Server.

So, at this point I have uninstalled 10D and will reinstall and try 1 more time to see if perhaps I missed a 'click' or a 'radio button' of some sort.

Worth mentioning perhaps, during the 10D install, it does not prompt me at any point to install MSSQL and it doesnt show in Add/Remove Programs.

Follow-up ideas are appreciated!

 

 

 

JustTryinToGetItToWork's picture

ok.

Only 1 question remains....

I reinstalled 10D in my VM and set the server name in my VM to be the same as my production server.

This worked.

(Interestingly, when I ran Beutil.exe on virtual server it did not recognize the media server. Even when I added it, it didnt recognize it. It said status of "unknown".

I had to stop services from services.msc instead.

 

At this point, how do I get the "updates" for this server? We are using a standalone and it doesn't have an internet connection.

Thank you in advance!

 

lmosla's picture

Unfortunately, because it is such an outdated version, Backup Exec 10d is no longer supported and there isnt much information on it but check out the following link http://www.symantec.com/docs/TECH53335   and seriously consider upgrading to Backup Exec 2010R3 SP3.  

This would require a multistep upgrade or a clean fresh install.