Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Ready; No idle devices are available

Created: 21 Mar 2013 | 10 comments

I'm new to Symantec Backup Exec as I've taken over the duties of someone else that left the company.  The problem that I'm having is I can't get Backup Exec to backup anything, not to tape, not to a shared drive, etc..  Logically I would have thought the issue was that the previous employee had used his account for all Symantec functions, I was able to change his account information for all the services and the connection to the server.  Everything appears to be fine, I'm able to do a Test Run without any problems but when I go to do a backup I don't receive any alerts I just get a message that says "Ready; No Idle devices are available".  Same result no matter where I try to backup to.

Anyone seen this before, have any suggestions of how I can fix it?  We're using Backup Exec 2012 S1a.  Thanks

Operating Systems:

Comments 10 CommentsJump to latest comment

VBU's picture

Hello Cyprusg21,

 

Please restart the backup exec services and once. Please go to the devices and try to Pause and Unpause the Server name there. Please try an inventory on the drives and see if that works.

Larry Fine's picture

"No Idle devices are available" is typically not a credential issue.  It indicates that your storage targets are not available.  This could be offline or busy stuff on the storage tab.  Or it could be jobs that are targetted to old/missing devices.

What tape are you using?  drives?  robots?

Is your disk target just a simple local backup-to-disk folder?

If you find this is a solution for the thread, please mark it as such.

Donald Eady's picture

Cyprus

 

         Please verify that the device that youre backing up to be it tape or a disk location is online/not disabled and unpaused.

Below are screen shots of devices paused /disabled... found under the storage tab

 

both can be remied by right clicking and either unpausing or enabling... try running job again

devices disabled.JPG devices paused.JPG

I hope this posting was helpful

  

Cyprusg21's picture

Yeah, I'm trying disk target right now to just a local folder.  Everything is online, Test Run works, Inventory works, everything but the backup works.  Tape is the same result.  I've reboot the services, rebooted the server, etc..

VBU's picture

Have you tried to pause/Unpause the server and the devices?

Cyprusg21's picture

Yep, I've tried pausing/unpausing with the same result.

IHCRC's picture

Take a look under your storage. Right click a storage device, and select Details from the context menu. For each device, check and see if "Limit Backup Exec to read-only operations" is set to yes. If so, toggle to no.

I have no idea why BE does this, but it does, and each time it's a pain to find it again. The software will work flawlessly for weeks and then suddenly decide everything is read-only for its purposes.

Tony Lombardi's picture

I didn't ask the question, but I had the same problem at a client location.  Thanks IHCRC.  Your post was right on target.  The disk used for the backup was limited to read-only operation.  I changed it and the backup began.  Such a simple solution!

 

MusSeth's picture

make sure no other jobs are running at the same time and that device is not busy, you can check this in device details

storage1.PNG

 

storage2.PNG

 

storage3.PNG

Biker_Dude's picture

On the Home tab, check the Active Alerts section.  Be sure the Time is set to show All because the default is 'Last 12 hours'.  Then see if there is a pending alert pertaining to a recent job.  You can also see if there are pending alert by looking at the Alerts count for each type at the bottom edge of the UI.

Also, check if the Job Queue is on hold.  Go to the 'Backup and Restore' tab and look to the right side of ribbon.  There is a 'Hold Job Queue' button there...see if there if it's box is checked.  If it were, you should have also noticed the warning 'The job queue is on hold' when viewing the Storage.

Hope this helps.