Video Screencast Help

Realtek 8169 error when using PC-DOS

Created: 08 Aug 2014 | 3 comments

Hello Experts,

I am looking for some assistance with an issue i am having creating a Ghost Multicard template boot disk.  Several of the machines running in my current environment are Optiplex 3020s using the realtek NIC.  I have downloaded the drivers off of Dells website as well as realteks website and both result in an error when i create a boot disk using those drivers.  The error i get is

Ethernet Adaoter driver (V1.35) [2010/12/14] installation failed

Serious internal error !

Not sure what causing this issue.  So i tried older drivers that came with boot wizard and they worked.  However, when i add it to multicard template it cant load/find the drivers.

Any assistance would be greatly appreciated.

Operating Systems:

Comments 3 CommentsJump to latest comment

EdT's picture

It really is time to consider a move to WinPE as this has none of the limitations of DOS and is much more compatible with modern hardware.

However, in your DOS environment, what are the contents of Config.sys and Autoexec.bat ?  It is possible that you are running out of base memory in your DOS environment, so it would be helpful to check whether your setup is using extended memory to load some of the drivers "high".  For completeness, it would be interesting to see what is in the protocol.ini and system.ini files as well.

Finally, you might want to check out the "NetBootDisk" website at

This site has a DOS based bootdisk that handles dozens of different network cards and I've used this with Ghost on many occasions as it saves me having to locate drivers and figure out the INI file settings.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.'s picture

I have been using PE environment for a while until i ran into an issue with finding vista drivers.  DOS drivers seem easier to come by so i am trying to switch to PC dos, its also much faster when booting with PXE.  Here is the protocol.ini of the nic



drivername = rtend$
; Medium type 
Medium = _Auto
; (optional) Network Address
; NETADDRESS = @000000000000
; (optional) Node Address
; ETHERID = @000000000000
; (optional) Adpater's Bus Number
; BusNo = 0
; (optional) Adpater's Device Number
; DeviceNo = 0
; (optional) Adpater's TX Early Threshold
; TxFiFo = 5


@echo off
SET TZ=GHO+08:00
prompt $p$g
echo Loading...

CONFIG.sys contents

DEVICE=\net\protman.dos /I:\net

not sure which system.ini file you are refering to.

EdT's picture

The config.sys loads HIMEM.SYS but the rest of the entries in both config.sys and autoexec.bat do not appear to use it at all.

In Config.sys, try replacing DEVICE= with DEVICEHIGH= for the three .DOS drivers and see whether this completes without errors. (This is generally a try it and see manoever for each entry).

In autoexec.bat, try replacing

\net\ with LH \net\

and also

if exist MOUSE.COM LH MOUSE.COM   (LH=LoadHigh)

Again, this is a try and test approach as not all drivers will allow themselves to be loaded into high memory, but at least if some of them do, it leaves more base memory available for the other drivers to load.  You can also try putting a REM at the beginning of the: if exist, etc line, as some mouse drivers can cause issues as well.

What version of PC DOS are you working with by the way?

Finally, you may be interested in this article on how to build a WinPE V3 boot environment for use with Ghost:

This version allows you to use Win 7 drivers.

Users have reported that imaging with PCDOS appears to have a limit of around 24-26Gb on the raw image size so you may have issues if imaging a large Win 7 install.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.