Video Screencast Help

Recover MSCS cluster quorum in Dynamic Disk Group

Created: 21 Mar 2011 • Updated: 01 Jun 2011 | 2 comments
This issue has been solved. See solution.

we have SFW w/ Cluster Option and the MSCS quorum is a dynamic volume. OS is Windows 2003 64-bit

i'm trying to recover the whole cluster (two nodes) in a DR situation, with different hardware. (assume both nodes are down)

we have backup of the OS and quorum disk w/ Symantec BackupExec System Recovery. 

on the 1st node, after restore the OS, Windows boot up ok. then i reconnect all the shared disks. ok. Then from within Windows, i restore the quorum disk from BESR (but the option "Restore original disk signature" was unable to select - gray-out) - it seems the content are restored to quorum disk. but the Cluster Service cannot start. the cluster.log shows some error about unable to locate quorum disk signature.

what is the proper procedure to recover a MSCS when the quorum is on a Dynamic Disk Group? 

i tried to restore the disk signature using dumpcfgx64.exe and other tools but does not seem to work?! 

anyone can help? thanks!

joseph.

Comments 2 CommentsJump to latest comment

rhanley's picture

Hi Joseph,

    This appears to be an issue with or without SFW installed. I came across this technote written by the BackupExec team, and I hope this information provides you with the proper method to ensure you're able to restore your quorum, even with a different disk signature.

http://www.symantec.com/business/support/index?page=content&id=TECH59697&key=15047&actp=LIST

Please let me know if this works for you. If you run into any problems or need further assistance, it is probably best to post this same question to the Backup Exec Forum or to open a Support case with them.

I also came across the following Microsoft article that discusses a utility that can be used to assist in recovery: http://support.microsoft.com/kb/305793

I hope this helps,
rhanley
 

SOLUTION
Jay Kim's picture

If I'm not mistaken, disk signature doesn't come into play if the Quorum is "dynamic" as that only applies to physical disk resources only. Dynamic Quorum diskgroup is basically just another VMDG resource inside MSCS and nothing more.

So if the Quorum VMDG resource is able to online and import the correct Dynamic Quorum cluster diskgroup, then as long as MSCS is configured to point to that VMDG resource to use as a quorum, it should work regardless of the disk signature. 

So maybe you had a physical disk resource pointing to the single quorum harddisk which was dynamic at the time?

Please mark my post as solution to help others also if it resolved your issue.