Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Recovery Issue using Symantec System Recovery Desktop 2013

Created: 01 Apr 2013 | 5 comments

Looking for assistance, if anyone can help!  

 

Background information:

I backuped a computer running Windows XP Home Edition using Symantec System Recovery Desktop Edition 2013.  I tried to restore the image on a computer with different hardware to see if the restore would work.  I'm receiving the following error.  System file is missing or corrupt \system32\drivers\nvstor.sys

 

As you can see the root directory "windows" is missing.  I'm able to go into the F8 load menu and do a safe mode with command prompt.  I can see the system is loading other drivers using \windows\system32\drivers\ folder, but this specific driver loses the root directory.  I'm able to load this restore fine using a VHD to Virtual Box on another desktop, but I need to restore the system on a PC with different hardware.  I've tried multiple restores using various options.  With/without restore MBR, different hardware option, etc..., but the results are the same.  

 

Has anyone encountered this issue before?

Operating Systems:

Comments 5 CommentsJump to latest comment

Andy H.'s picture

Does the error occur during the restore process, or after the reboot?

From your description, it appears that it's after the restore is complete. This driver appears to be related to nVidia. If you can get into safe mode, try setting your display driver to a standard VGA driver. While in Safe Mode, go into your Add\Remove Programs in the Control Panel and uninstall any thing nVidia related.

Andy Horlacher

Please mark this thread as 'solved' if it answers your question

KennyH's picture

It happens after the restore.  The restore appears to be successful.

If I'm using restore anywhere, should the restored image even contain anything nvidia related?  I thought the restore anywhere provided the base drivers.

 

Andy H.'s picture

The Restore Anyware attempts to put the display driver to a Standard VGA. nVidia likes to load other software on startup during the boot process that depend on the nVidia driver. My guess nVidio software loading up is looking for that file, and failing. Hopefully uninstalling any nVidia software and ensuring the driver is Standard VGS will remedy that. 

Andy Horlacher

Please mark this thread as 'solved' if it answers your question

KennyH's picture

Ok, looked at the client computer.  Doesn't have anything NVidia.  Still having the same issue.  The computer I'm trying to restore on does have NVidia.  Why it loses the root folder on this driver is beyond me, the nvstor.sys is not even on the computer that was backed up.

Dave_H's picture

nvstor.sys is for a NVIDIA nForce Serial ATA Controller.  It's present in the driver database of the SSR recovery disk so if it's not present on the source system then restore anywhere must be injecting it.

I would guess the target system has nForce SATA.  When your restoring it into a virtual system it's using a different driver and thats why you don't hit the same problem.

Sorry that doesn't help you much, perhaps you can try manually loading another version of the nvidia 32bit driver for that motherboard.

 also have no idea why "windows" is not shown on the error path, I can see the driver correctly lists the path: %%SystemRoot%%\System32\drivers\nvstor.sys

(Make sure your using the 32bit recovery disk by the way since there is no such thing as XP Home 64).

Dave