Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Redeployment Managed Computer menu not consistent

Created: 31 Dec 2013 • Updated: 05 Mar 2014 | 5 comments
This issue has been solved. See solution.

I upgraded to 7.5 yesterday.  After fumbling around for awhile, I was able to find the settings to get the redeployment menu to show for already managed computers, but it's not consistent.

I couldn't get the menu to show on the first machine I tried (it had been powered off since before upgrade, agents not updated on client).  I thought maybe the deployment agent needed to update so I powered it on to update and tried a 2nd machine.  

The 2nd machine was showing the menu properly consistently (agents were updated on this machine).  Then I decided I wanted to change the text of the prompt, did that in NBS General Settings with "Apply NBS settings immediately" checked.  Confirmed on server when I made the change that config was requested and changed.

Rebooted 2nd machine and it didn't prompt, went right to "Symantec NBS pre-select automation processing" and booted to production.  Rebooted and same thing.  Restarted Symantec Network boot service on server and no change.

Rebooted up 1st machine that had not worked previously, and it correctly sees the redeployment managed computer menu and the new prompt text now.

Rebooted 2nd machine a few times, and it continued to not show boot menu, then it just started working again (and so far consistently).

When making a change to NBS General Settings, is there some cache on the server that needs to clear itself out, or some time period that needs to pass for agents to work as expected?  Or how can I troubleshoot if this issue continues to happen, where some managed machines aren't getting the menu ?

Also, can someone confirm if the DS agent on the client needs to be updated to see the menu?

Thanks, as always

Operating Systems:

Comments 5 CommentsJump to latest comment

Sally5432's picture

Seeing this again without making changes to NBS General Settings.  Got the menu, booted to PXE, rebooted to test again and now am not getting the menu (just going back to Symantec NBS pre-select automation processing).  So frustrating.

---
Don't forget to mark posts as helpful if they are, and mark answers as solutions.

Sally5432's picture

Anyone have suggestions... still having trouble with this from time to time with 7.5

Example today - 

New computer, out of the box, PXE booted but missed the initial deployment options because I got a phone call. Intitial deployment menu timed out and rebooted to production after timeout.  Production environment on this machine is new out of box windows set up (no client agent on machine).
 
I powered machine off.  Now I canít get it to go back to PXE.  Iím not given option to hit F8.. it just quickly flashes by ìNBS Pre-Select Automation Processing..î and boots back to out of box widows set up.
 
Pre-7.5 Iíd look in console for a record starting with minnit.. and send a job to that - but thereís no such minnit record for this machine.
 
 
Thanks for any help/suggestions.
 
 

---
Don't forget to mark posts as helpful if they are, and mark answers as solutions.

eladio's picture

Hello,

Did you restart de pxe services? When you try to boot by pxe the machine MAC will be marked in SMP pxe, so if a task fail or still pending , it will just work again after some minutes i think by default 30 minutes, try restart the pxe services.

Sally5432's picture

Consider me shocked - just checked console for new computers and this new out of the box machine is in there by serial number (no more minnit?!!!)

Sent job to it and it's going.  Score!  Thanks anyway eladio.

---
Don't forget to mark posts as helpful if they are, and mark answers as solutions.

SOLUTION
eladio's picture

Im glad to help you resolving your problem!

Yes, in new version appears the machines serial number.

what is the version of your smp? Now we are in 7.5 hf4

Please mark the post has resolved, to be close.