Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Regex not working with Encryption Server mail policy

Created: 05 Mar 2013 • Updated: 03 Apr 2013 | 2 comments
This issue has been solved. See solution.

Encryption server Platform 3.3.0 (Build 8741)

I have created a regex to capture a social number in "The email body" seperated by asterisks.  i.e.123*45*6789.  The regex tests fine in the dictionary as a pattern.

However when added to an enabled policy the mail goes through un-encrypted.  I have tried two different regex's .

^(\d{3}[*]-\d{2}[*]-\d{4})|(\d{3}[*]\d{2}[*]\d{4})$  and this one \d{3}\W\d{2}\W\d{4}.  Both retrun a result in the dictionary test.  I don't see any other policys that conflict with it, and have tried to move the policy up and down in the policy chain.  Symantec tech support was not able to resolve and ran into the same issue I do.  Anyone have a suggestion?  Thank you, Caribou.

Operating Systems:

Comments 2 CommentsJump to latest comment

dcats's picture

Try this:

([0-9]{3}\*[0-9]{2}\*[0-9]{4})|([0-9]{3}\*[0-9]{2}\*[0-9])

Note: you may need to fine tune it.

cariboujohn's picture

dcats, I just put that in our dictionary and it's working correctly.  Thank you!!  Timing is good too as we got tagged on that during a recent audit and needed to remediate.

SOLUTION