Video Screencast Help

Remote agent installations fails

Created: 27 Mar 2008 • Updated: 21 May 2010 | 7 comments
Hi all
 
After upgrading Backup exec to v.12, all except one server accepted the installation of the remote agent.
 
I have tried uninstalling/installing several times but no luck, same error.
 
Basicly in the log files it gives these errors:
03-27-2008,00:02:25 : The current user does not have write access to the C:\WINDOWS\Installer directory.
03-27-2008,00:02:25 : The current user does not have write access to the C:\Program Files directory.

03-27-2008,00:02:25 : The install could not verify that the user has rights to required install folders.
Now I have checked those permission, and they appear correct
During the installation it hangs when the backup exec service is starting (keeps saying starting)
 
Does anyone know how to get more details of those errors.
 
Best regards
 
Benny
 

Comments 7 CommentsJump to latest comment

Ken Putnam's picture
Try a "silent" install
 
On the problem computer logon as Admin and see page 96 of the Admin Guide or
 

If this response answers your concern, please mark it as a "solution"

BackupMAN's picture
Hi again
 
thanks for your advise.
 
Did the remote agent installation by commandline and infact something new happened, but the service still hangs (starting) when trying to start.
 
Log:
03-28-2008,10:13:05 : ERROR: Error 1920.Service Backup Exec Remote Agent for Windows Systems (BackupExecAgentAccelerator) failed to start. Verify that you have sufficient privileges to start system services.
03-28-2008,10:17:13 : A fatal error occurred during installation on server 'WEBPROD'.
03-28-2008,10:17:13 : ERROR: Installation failed with error 1603.

Anyone has a solution for this?
 
Best regards
 
Benny
BackupMAN's picture
Hi
 
Any official Symantec supporter who could comment on this?
 
thanks
 
Benny
Dev 2's picture
Hi,
 
Lets perform a "silent install" of the remote agent and see what happens
 
# Silent Install for a 32-bit Remote Server:
1. On the Backup exec server:
    Go to X:\Program files\Symantec\Backup Exec\Agents folder and Copy RAWS32 folder on the C-Drive of the
    Remote server.
2. Go to the Remote server and open the command prompt
3. Navigate to the RAWS32 folder...Ex: C:\RAWS32>
4. run the following command "setupaa.cmd" (Without Quotes)...The cursor will come down and Blink for some
    time. After some time we will on the command Prompt again...
5. The remote agent is installed now.
6. To verify open the services.msc Window and check if Backup exec Remote agent service is running or not.
 
# Silent Install for a 32-bit Remote Server:
 
1. On the Backup exec server:
    Go to X:\Program files\Symantec\Backup Exec\Agents folder and Copy RAWSx64 folder on the C-Drive of  
    the Remote server.
2. run the "setupaax64.cmd" rest everything is the same.
 
Regards
 
Dev T
BackupMAN's picture
Thanks, but that was already suggested and tried out in reply 1, this makes the installation hang and the service hanging in the status "starting".
 
Best regards
 
Benny
DallasITGuy's picture
I am having this exact same problem.  I was at a customers site this weekend, and this failed accross 20+ servers, including Windows 2000, Windows 2003 Server, both 32 & 64 bit.  All with the same error.  The account I am using DOES have rights to those folders, but am still getting the error.  The biggest problem is the install crashes mid-install, and does not clean up after itself.  I have successfully* finished 1 agent install out of 20, and it's taken days. When I say successful, the only way I could get it to install was to copy the agent over manually, make 100% the previous install attempts were manually cleaned up, and rename the msi patch file so that it would not try to install.  Question is, what dose that patch file do?
 
In the logs of my first installs, it makes it all the way to the end, starts to install the patch, then states this:
 
04-05-2008,11:39:35 : === Logging stopped: 4/5/2008 11:39:35 ===
04-05-2008,11:39:35 : Windows Installer return: 0
04-05-2008,11:39:35 : found patch file.
04-05-2008,11:39:35 : Valid patch file.
04-05-2008,11:39:35 : ERROR: Installation failed with error 1603.

After that, if I tried to install again, it would start to fail earlier, crash during mid install, and create a mess.  I had to install a Microsoft tool to cleanup the Install "Windows Install Clean Up".  I also had to delete the Symantec folder under Program Files Manually, and have also been deleting the log, and any other places the install touches to try to get it back to default before each install.

So my question is.. I finally got the agent to install, but the patch was not applied.  Can someone post the patch version of the last successful agent installed?  Also, anyone having problems, can they post their RAWS.msp (32-bit) info?

 

32-bit RAWS.msp

Created & Modified:  Monday, March 17, 2008, 10:39:36 AM

Size:  761 KB (779,776 bytes)

Under Summary, Revision Number:  {B80B4EF7-3250-463B-97F9-F2FDA2C2CF74}

 

64-bit RAWS64EX.msp

Created & Modified: Monday, March 17, 2008, 10:41:35 AM

Size: 1.06 MB (1,116,160 bytes)

Revision Number: {F9B3EF90-E24D-4DF5-A851-B65DF55D4918}

 


DallasITGuy's picture
Ok, so it looks like Symantec Backup Exec Remote Agent for Windows Systems.msi haven't been edited or modified since 2006... so I'm guessing it's the patch file that actually does most of the updating?  So me being able to do the install but not apply the patch is really doing me no good, as my agents report back being 11.x when my media server is running 12.  Is there any reason why they would not be installing correctly?  It doens't even give an error other than what I posted above.  Is there another place to look for more info on errors?