Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Remove a media server/drive from Netbackup

Created: 08 Feb 2013 • Updated: 02 Apr 2013 | 3 comments
This issue has been solved. See solution.

I've been struggling these days to remove an offline drive/Robot from Netbackup and it says already in use eventhough all the tapes are expired etc.

NBU never let's you delete the drive when tried from the console to delete the drive/Robot.

If you ready to EOL the environment, simple solution would be go to NBU Console -> Devices -> Media servers, right click the Media server and say Remove Device Host

It knocks off all teh association including drive/Robot provide there are no tapes/storage unit which we can delete manually

Comments 3 CommentsJump to latest comment

Marianne's picture

Deleting devices through the GUI requires media server to be online.

If media server is offline, you can use:

nbemmcmd -deletealldevices -machinename <media-server_name> -machinetype media

Another option is to decommission media server:

http://www.symantec.com/docs/HOWTO43775

http://www.symantec.com/docs/HOWTO72806

http://www.symantec.com/docs/HOWTO66666

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
RamNagalla's picture

what is the Version of Netbackup you are using, if its NBU 6.X or7.X use below tech note

http://www.symantec.com/business/support/index?pag...

if this tech note did not help you, please come with the exact error code when and where you are getting..