Video Screencast Help

removing EV comuter from EV Console

Created: 29 Aug 2012 • Updated: 23 Oct 2012 | 9 comments
This issue has been solved. See solution.

Hello,

I wonder if anyone can help me on this query....

I have an EV server and recently I needed to install Enterprise Discovery Accelerator on a separate server and accidently after installing the EV binary files of the Discovery Accelerator I run the EV configuration setup and therefore I end up with two EV servers under the "Enterprise Vault Servers" section in the Ev management console.

 

I tried to remove it by uninstalling EV on the Discovery Accelerator and then from the main EV console I tried to delete the second server by right click and select delete but I am still getting this error message. " This computer contains services. You need to delete all these Services before you can delete the computer".

Any suggestion will be appreciated.

Comments 9 CommentsJump to latest comment

EVRocks's picture

Hi Amol,

I am afraid it's a bit too late to follow Tony's steps.

No tasks or services have been setup on the second server other than Discovery Accelerator service. So what i did is first uninstall EV on that server and on the console I am only seeing one service "Shopping service" with status of error for this server but I can not remove it. I am getting this error: "Could not determine if the Enterprise vault server running on <servername> is part of a cluster. Class not registered."

Checking the properties of this service I noteid it point to a path on the senond server but that path does not exisit anyloner since the EV was uninstalled.

 

I can see what went wrong I unistalled EV first before removing the services. I guess registery keys now the only options.

 

John Ludlow's picture

Hi,

Sorry for the late comment - just came across this post recently.

Not sure if this issue is still current or if you found a workaround, but in this situation you can use the Services control panel to see what services are still registered, and use sc delete to get rid of them. sc.exe is a tool built into Windows, so you can use it without having EV installed.

For example:

sc delete EnterpriseVaultShoppingService

This will (unsurprisingly) delete the EV Shopping Service. Double click the service in the control panel and check the Service Name field to find out the name you need to use (It's the one without any spaces).

Hope that helps

EVRocks's picture

Hi John,

Thank you for your respond. I am a fraid this would not work because the services have been removed after uninstalling EV. You see I uninstalled EV on the DA server so services and even the path does not exists any longer.

I guess by options now will be editing registry key and the database tables.

 

someone suggested to reinstall EV on the DA server then start stopping and then removing the services. but I am cautious that might add another server to the list. and since then I have upgraded the EV server from 8 to 9. but I have not upgraded the DA server because I will crashing it and rebuilding it.

Cheers,

 

John Ludlow's picture

Hi,

Perhaps I misunderstood the original issue.  Do you mean that if you log onto that machine (the machine you mistakenly installed EV onto) and open the services panel, you don't see any EV services?

If you expand the server node under Enterprise Vault Servers, do any items appear under Services or Tasks?

Thanks

John

Nups's picture

Hi,

You can remove the shopping service as mentioned in the steps in the tech note below:

http://www.symantec.com/business/support/index?pag...

Hope this helps.

cheers...

Thanks and Regards, Backup Exec, BESR, Enterprise Vault

SOLUTION
Nups's picture

With that said I assume that you backup the databases before you make changes to it.

Thanks and Regards, Backup Exec, BESR, Enterprise Vault

EVRocks's picture

Hi Guys,

Correct - no EV services. On the DA server where I have uninstalled EV and there are no services nor any EV folder path. Only DA service running.

On the main EV server (the only one) where I need to move the second EV server. I only see one service "shopping service" whcih I tried manually to delte and this is where i get the error. There are no Tasks running. I have a ghost/orphant service which can not be delete it.

Baiscally as I explained I supposed to uninstall EV on the DA server before deleting services on the EV server.

cheers guys.

 

 

TypoProne's picture

So to do this you have to remove the entries from teh DB. It can totally be done and is a slightly involved process. If you call up support there is an internal technote describing how to do this. The issue is that sometimes you may not get someone who is too comfortable with the steps . Really anyone on the ADV team or up should be comfortable with it.

 

Sometimes what happes is there is still data assocated with the various components you are tattempting to remove. For example you may want to remove a storage service that still refernces a vault store... or an indexing service that still references a specific archive. You have to clear all these constraints. Depending on how your system was set up and what moves you did prior to just removing the services will depend on how easy it is to clean up. I would certianly backup your databases prior to calling support and request their assistance. If you do not there is potential to mess something up or be declared unsupported for manually fiddling in teh DB yourself. 

 

Another option woudl be to set up the server again and remove it using Tony's posting above.

 

I hope this helps and you still needed help. If you did not need help please either post your solution and flag it or flag the posting above that helped you to resolve it. This helps to make sure that those seeking to help ...help where it is most needed.

 

Many thanks and good luck.

 

Regards.