Video Screencast Help

Replication Director status 84 (174)

Created: 19 Feb 2013 | 7 comments


We have configured Replication Director on NBU as per Replication Director solution guide and various NetApp guides. Snapshots appear to be running without an issue, but when a snapmirror replication is attempted it fails with 84:

19/02/2013 19:04:43 - requesting resource LCM_STU_SLG_Snapshot_RDDP
19/02/2013 19:04:43 - granted resource LCM_STU_SLG_Snapshot_RDDP
19/02/2013 19:04:43 - started process RUNCMD (4712)
19/02/2013 19:04:43 - requesting resource @aaaal
19/02/2013 19:04:43 - reserving resource @aaaal
19/02/2013 19:04:43 - reserved resource @aaaal
19/02/2013 19:04:43 - granted resource MediaID=@aaaal;DiskVolume=PrimarySnapshot;DiskPool=Primary_RDDP;Path=PrimarySnapshot;;
19/02/2013 19:04:44 - Info bpdm(pid=6584) started            
19/02/2013 19:04:45 - started process bpdm (6584)
19/02/2013 19:04:47 - Info Adding storage server, disk volume Slough_test to target storage server list
19/02/2013 19:04:47 - Info Using OpenStorage to replicate backup id GRWST003_1361292502, media id @aaaal, storage server, disk volume PrimarySnapshot
19/02/2013 19:04:47 - Info Copying snapshot (size=604929978368) to target storage server      
19/02/2013 19:04:55 - Error (pid=4712) ReplicationJob::WaitForReplicationCommandStatus: Replication failed for backup id GRWST003_1361292502: media manager - system error occurred (174)
19/02/2013 19:04:55Replicate failed for backup id GRWST003_1361292502 with status 174
19/02/2013 19:04:55 - Error bpdm(pid=6584) <async> copy snap failed: error 2060001: one or more invalid arguments  
19/02/2013 19:04:55 - Error bpdm(pid=6584) copy of snapshot <snapinst><type>CREATE_HANDLE</type><version>1.0</version><ds_mem_info><path>/GIRNW5D_DATA13/DATA13</path><src_volname>GRWST003:/GIRNW5D_DATA13</src_volname><dir_path>DATA13</dir_path><qtree>GRWST003:/GIRNW5D_DATA13/DATA13</qtree><dsmem_path>GRWST003:/GIRNW5D_DATA13/DATA13</dsmem_path><snap_name>GRWST003_GIRNW5D_DATA132013_02_19_04_48_39</snap_name><filer>GRWST003</filer><share_name>/vol/GIRNW5D_DATA13/DATA13</share_name></ds_mem_info><NBU_RECV_EXPORT_HOST>GRWST003</NBU_RECV_EXPORT_HOST><dataset>NetBackup_create_import_1361268638</dataset><backup_version>1361292519</backup_version><backup_id>9</backup_id><size_used>604929978368</size_used><snaptype>primary</snaptype></snapinst> failed: error 174      
19/02/2013 19:04:55 - Info Canceling replication for backup id GRWST003_1361292502, storage server, disk volume PrimarySnapshot
19/02/2013 19:04:55 - Error bpdm(pid=6584) <async> cancel failed: error 2060001: one or more invalid arguments   
19/02/2013 19:04:55 - Error bpdm(pid=6584) cancel of snapshot <snapinst><type>CREATE_HANDLE</type><version>1.0</version><ds_mem_info><path>/GIRNW5D_DATA13/DATA13</path><src_volname>GRWST003:/GIRNW5D_DATA13</src_volname><dir_path>DATA13</dir_path><qtree>GRWST003:/GIRNW5D_DATA13/DATA13</qtree><dsmem_path>GRWST003:/GIRNW5D_DATA13/DATA13</dsmem_path><snap_name>GRWST003_GIRNW5D_DATA132013_02_19_04_48_39</snap_name><filer>GRWST003</filer><share_name>/vol/GIRNW5D_DATA13/DATA13</share_name></ds_mem_info><NBU_RECV_EXPORT_HOST>GRWST003</NBU_RECV_EXPORT_HOST><dataset>NetBackup_create_import_1361268638</dataset><backup_version>1361292519</backup_version><backup_id>9</backup_id><size_used>604929978368</size_used><snaptype>primary</snaptype></snapinst> failed: error 174      
19/02/2013 19:04:55 - end operation
media write error(84)

DFM server comes up with the following error


q_417ywbup0: There are no data protection relationships for connection 1 of dataset NetBackup_GRWST003_GIRNW5D_DA_q_417ywbup0 (14156) and the source node has data to protect so the update from the primary node to the secondary node has failed. Please check the conformance status of the dataset.

We are using NDMP type policies and the filers are specified in the clients section and the volume in the file list section

I realise there's not a great deal to go on here but hoping someone somewhere has seen something recognisable in this :)

Thanks in advance


Discussion Filed Under:

Comments 7 CommentsJump to latest comment

Marianne's picture

Best to log a Support call ASAP. 

I guess hardly any forum members have any experience with Replication Director.

Please keep us updated!

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Chrisb2k's picture

Call logged yesterday ;)

Our Symantec contact has suggested we look at the ndmp credentials on the OnCommand server itself. I guess this would cause problems if Netbackup couldn't create the snapmirror relationship through OnCommand via the ndmp login, though I don't recall any mention of having to do this in the guides. I may be wrong ...

I'll keep you posted


rharriso's picture

Hi Chris, my name is Richard Harrison and I am the Product Manager for Replication Director.  I noticed your situation and was wondering whether your issue was resolved via your case with support.  We don't want to circumvent the support process, but if we can help you we want to.  If there is anything the product team (PM, development, QE) can do to assist, please let me know.

Chrisb2k's picture

Hi Richard

Apologies for the delay in replying. I've not actually heard back from the customer whom I was doing the work with so I don't know whether it was resolved, but last I heard the snapmirror side was working too. 

A number of things were tried in an effort to get it working in the end but details of exactly what are sketchy. I believe NDMP credentials may have played a part, possibly adding global credentials for the media servers rather than having distinct ones for each media server.

I'll update if/when I hear anything more meaningful.

Stumpr2's picture

Hi Chris, I am subscribing to this thread as I will be coming down this path too  :-)

Not sure when, but soon.

VERITAS ain't it the truth?

Chrisb2k's picture

As long as it's not a multi path you are coming down ... :)

I do know that it was fixed but then it broke again, and that was definitely to do with NDMP credentials on the OnCommand server - someone changed the NDMP credentials to use from our "ndmp" user account to root without telling anyone. The next day, when I had left, I heard that it had once again broken but I don't yet know whether the reason was the same or different.

I'll be back at this customer site tomorrow so will be able to update on progress.

Symboy's picture


  Any one have any update on the above issue  ?

Note: If this post provides you with a solution don't forget to mark the discussion as solved.