Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

replication issue between two SEPM servers

Created: 17 Oct 2013 | 10 comments

Hi,

 

i am currently using SEPM 11.0.61 version. i have two servers replicating to each other. from last few days, replication is not happening between both of the servers. please help. Database i am using is sql 2005.

 

Thank You

Deepak

Operating Systems:

Comments 10 CommentsJump to latest comment

pete_4u2002's picture

can SEPM's communicate on port 8443?

can you look into tomcat logs for more information on why it is failing?

 

SameerU's picture

Hi

Do you have any firewall between

Regards

 

Chetan Savade's picture

Hi,

Thank you for posting in Symantec community.

This Replication log captures information related replication.

File Location: C:\Program Files\Symantec\Symantec Endpoint Protection Manager\Tomcat\Logs\Replication-0.log

I see following fixes in the previous SEP releases:

Replication fails between two sites
Fix ID: 2087986
Symptom: Replication between two sites may fail if a firewall between the two sites is configured for a low TCP idle session timeout.
Solution: A session keep-alive feature was added for replication to ensure the connection remains open for the duration of the replication.
 
Replication fails due to deadlock during ReplicationTask
Fix ID: 2253188
Symptom: Replication fails due to deadlock during ReplicationTask while processing SEM_CONTENT_DEL table.
Solution: The batch size for table replication was increased to resolve this issue.
 

Considerations: Before setting up replication.

    1. Minimise number of Sites - Ideally below 5

    2. Network Bandwidth and Link

    3. Network Latency.

    4. Database Size on the Primary site.

    5. If any Firewall, Proxy, Router, etc. exists between 2 sites.

Reference:https://www-secure.symantec.com/connect/articles/replication-and-considerations

 

Chetan Savade
Sr.Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<

Ambesh_444's picture

Hello,

Please update the thread..

 

Thank& Regards,

Ambesh

"Your satisfaction is very important to us. If you find above information helpful or it has resolved your issue. Please don't forget to mark the thread as solved."

Cameron_W's picture

I noticed you mentioned you are running SEP 11 with SQL 2k5. This may be unrelated but there is currently a issue with definitions not updating with SEP 11 and SQL 2k5. Below is the documentation regarding this and the fix.

http://www.symantec.com/docs/TECH211503

If I was able to help resolve your issue please mark my post as solution.

AravindKM's picture

Is there any error present in scm-server.0.log?

Please don't forget to mark your thread solved with whatever answer helped you : ) Thanks & Regards Aravind

SameerU's picture

Hi

Please update on whether you have any firewall policies

Regards

 

A. Wesker's picture

Hi Deepak,

 

It would be hard to provide blind troubleshooting, can you provide more details about your replication issue.

Firstly, did the replication work before ?

Secondly, what contents you replicate between you both server ? No option checked means strictly Database, Groups, Policies. If you have checked some boxes such as logs and sep package and liveupdate contents it can have an impact on the data.zip size transfered between your both servers.

As Pete already asked, replication uses the port 8443. Did you check if that traffic is allowed between your 2 SEPM server ?

Third, did you schedule your replication to run once per day or once per week ? If not, it's not really advised to set it up to "Auto-Replicate" because it could lead to a lot of database locked everytime there is a change on one of them (every 5 minutes).

FYI, Replication, Live Update and Auto-Upgrade use a common process so if any of them is running, your replication can fail. It's advised to have a proper schedules for LiveUpdate and a different one for your replication.

Try to run a manual replication then upload scm-server-0.log and replication-0.log in order that we can see what happens.

 

Kind regards,

A. Wesker

Chetan Savade's picture

Is there any update on this issue?

Chetan Savade
Sr.Technical Support Engineer, Endpoint Security
Enterprise Technical Support
CCNA | CCNP | MCSE | SCTS |

Don't forget to mark your thread as 'SOLVED' with the answer that best helps you.<