Video Screencast Help

Replication throttling between data domains

Created: 14 May 2013 • Updated: 14 May 2013 | 5 comments
This issue has been solved. See solution.

Hi All

we have two DDs where we do netbackup managed WAN replication.

we are having issues due to the excessive bandwith usage by replication.

Any suggestions to throttle the bandwith for data transfers between DD's.

 

 

Operating Systems:

Comments 5 CommentsJump to latest comment

Nicolai's picture

This will be a hard nut to crack. I found this text in the NBU SLP bets practice:

http://www.symantec.com/docs/HOWTO73205

Bandwidth considerations
The network bandwidth required for Auto Image Replication is unpredictable to NetBackup, based on the fact that we have no way to predict in real-time the deduplication rate of a duplication image set, the Optimized Duplication throughput of the storage device, or current network traffic. Additionally, this is very likely to occur over a WAN which implies longer latencies and lower bandwidth in general. This is another reason that it is wise to plan accordingly and to ramp up slowly.
 
You can however try to limit the number of SLP than can run concurrent by enabling/disabling SLP during the day
 
nbstlutil inactive -lifecycle <lifecycle name>
nbstlutil active -lifecycle <lifecycle name>
 
http://www.symantec.com/docs/TECH170086
 
But even that may not be enough to limit the bandwith usage to an acceptable level.

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

RonCaplinger's picture

The Data Domains have replication throttling built in, and you can schedule when you might want those values to change.  This is effective even when NetBackup is managing the replications using OST, as NBU is just monitoring the replication handled by the DD's.

 

xxxxxxx@yyyyyyy# replication throttle show
 Time       Sun       Mon       Tue       Wed       Thu       Fri       Sat
 ----       ---       ---       ---       ---       ---       ---       ---
00:00 536870912 536870912 536870912 536870912 536870912 536870912 536870912

 ----       ---       ---       ---       ---       ---       ---       ---
All units in bps (bits per second).
Active schedule: Tue, 00:00 at 536870912 bps.
Actual throttle value (from kernel): 536871000 bps
SOLUTION
Nicolai's picture

Cool - I knew this option existed but did not know it worked with SLP also.

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

Nbuddm's picture

Thanks Nicolai & Ron for the response.

Yes I adjusted the Replication throttling settings on the DD.the n/w traffic looks good now.

teiva-boy's picture

Right depending on what version of the DDOS you are using, you can change this in the Managment web interface.  Cap the entire amount of bandwidth, or put a schedule to the cap.

There is an online portal, save yourself the long hold times. Create ticket online, then call in with ticket # in hand :-) http://mysupport.symantec.com "We backup data to restore, we don't backup data just to back it up."