Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Resource: "VMVCB::\\...\....\Server" is not snappable. Attempting to back up directly from the source volume.

Created: 11 Oct 2012 • Updated: 11 Oct 2012 | 10 comments

Hi Guys, Im getting this message (not error) for all my VMs when backing up:

Note: Resource: "VMVCB::\\vcenterserver\VCGuestVm\(DC)Datacenter(DC)\vm\SERVERNAME" is not snappable. Attempting to back up directly from the source volume.

Firstly this is reported against ALL my VMs and not just SQL and Exchange as most searches I found mentioned.

I guess Im just trying to understand why more than anything else. This isnt an error or causing any VM backups to fail. It works absolutly fine!

Im using BE 2012 SP1 with HF 1897571,180964, 194470. Utilizing the AVVI agent with GRT and GRT for Exchange and SQL. All my remote agents are updated to the latest version. Target is to dedupe using SAN transport.

Here is an form the job log:

Family Name: "Media created 10/11/2012 6:00:07 PM"
Backup of "VMVCB::\\server.domain.com.au\VCGuestVm\(DC)Datacenter(DC)\vm\SERVER
Backup set #1 on storage media #1
Backup set description: "Colo Prod Servers -VMs Full and Incremental with Full Monthly Duplicated to Tape-Weekly Full"
Backup Method: Full - Back up virtual machines
The option to enable the restore of individual files and folders from a virtual machine backup was selected for this backup.
The Agent for Windows must be installed on the virtual machine to use Granular Recovery Technology to restore data.

Backup started on 10/11/2012 at 10:38:34 PM.
Backup Set Detail Information
Media Label: IMG004058
GRT backup set folder: \\.pdvfs\SERVER\2\BEData\STHVMDK\IMG004058
Transport mode 'san' was used for the disk 'SERVER.vmdk'
Backup Exec has discovered and protected 'C:' on virtual machine 'SERVER.rocla.com.au'.
Backup Exec has discovered and protected 'D:' on virtual machine 'SERVER.rocla.com.au'.

 

Like I said It doesnt appear to be a problem, backups work fine as do restores but if anyone could shed some more light on it that would be great for my own peice of mind.

 

thanks!

 

 

 

 

 

Comments 10 CommentsJump to latest comment

Jaydeep S's picture

In the job properties, look for Advanced open file -> Is this checked. If it is uncheck all the 3 check boxes on this tab including Check Point Restart and try the backup.

Also is Backup Exec a physical box or a VM in th same enviornment.

Vlad Velciu's picture

I am having the exact same question and the exact same configuration. I would really like to know what exactly does this mean when backing up SQLs, Exchange, DCs, FileServers in a VM environment using AVVI.

lmosla's picture

Do you see any errors in Windows events under system or application that might identify if any application is interfering during the backup time window ( such as virus scans) ?

Vlad Velciu's picture

In my case, no. No out of the ordinary events. The backup process runs without problems and also the restore jobs. I was curiouus what does the message actually means: 

Note: Resource: "VMVCB::\\vcenterserver\VCGuestVm\(DC)Datacenter(DC)\vm\SERVERNAME" is not snappable. Attempting to back up directly from the source volume.

ConcordICT's picture

I am getting these messages too although the backup appears to work - what gives??

I even see the snapshots being created in v-centre, so what exactly is not snappable?

lmosla's picture

There are several reasons this error occurs. Check out this link that explains some of the thngs that could cause them.  One of the reasons is that something is disrupting the writers or causing the process to hang.

http://www.symantec.com/business/support/index?page=content&id=TECH129724

johnflint76's picture

I had this same issue and I resolved it.

 

I had copied some basic job settings when creating my VMware Backup Jobs. What I didn't realize is when I did this, it also copied the Windows VSS settings for Advanced Open File. Once I changed these setting to what is listed below, I no longer received the errors.

1. (check) Use snapshot technology

2. (radio button) Automatically select snapshot technology

3. (check) Process logical volumes for backups one at a time

4. (uncheck) Enable checkpoint restart

 

I hope this helps you like it did for me. It was a simple mistake on my part.

 

andygantc's picture

my initial backup settings are same with u. But i get the same error message. any idea? my backup are successfully performed. and all my vm are shutdown ( replicate from source site) during backup to tape. SO, i m not using GRT.Tqvm

 

Advanced open file settings.png GRT.jpg