Video Screencast Help

Restore archived data

Created: 09 Dec 2013 | 16 comments

I'm migrating LTO2 tapes to LTO5.  The LTO2 tapes were created using Backup Exec 12.5.  I've duplicated the jobs to disk and then to LTO5 tape in Backup Exec 2012.  I can search the media fine, I can see all the data is on the new tape.  I went to test a restore from the tapes but I can't get to the data on the tapes through the restore wizard. In some cases the server may be decomissioned entirely; others, I still have the server and either a) DO have the options to restore the data or b) DO NOT see the data to be restored.

Of the three scenarios (server decomissioned / server not decomissioned but can see the data / server not decomissioned but don't see the data ) I am only working on the last two.  The first scenario will be the point I'm trying to get to.

Am I doing something wrong?

 

Operating Systems:

Comments 16 CommentsJump to latest comment

lmosla's picture

have the tapes been inventoried and catalogued? Make sure the date occurance is accurate for the backup/restore. 

surfnturf81's picture

Imosla! You got me.

 

Of the 3 scenarios you have helped me with #3 (and #2 was always working).  I did not realize that the tapes I was looking at was a year older than I thought (and so I am missing an archive set!).

Thank you and once I've established an answer to scenario #1 I would like to request a split answer for you (I do not want to unintentionally close the thread at this time).

 

 

surfnturf81's picture

I'm not certain what you mean about the date occurence? You mean when viewing what items can be restored for the server?  Yeah I ticked back far enough.  And yes they are inventoried/catalogued. I don't think I could see the data w/o doing so.

lmosla's picture

Just to make sure I understand, you have duplicate the LTO 2 tapes (backed up by BE12.5) to disk and then backed them up to LTO 5 tapes successfully with Backup Exec 2012.  Now you are trying to restore these tapes but you are unable to because the contents are not showing in the restore wizard?

What type of files are these?

Have you tried to duplicate the LTO 5 tapes to disk and run the restore?

surfnturf81's picture

You are spot on with what I've done but let me clarify I am trying to restore parts of the data, not the whole tape.  They could be any type of data but I'm working on archived user data and a document imaging system.

I have not tried to duplicate the LTO 5 tape back to disk, it seems redundant? I do have copies left over from the intermiediate step to disk.

pkh's picture

If your server is decommissioned and there is no data to restore (scenario 1) then nothing will show on the BE console. If there is no data to restore why do you expect the server to show on the BE console?

surfnturf81's picture

I had no expectation, pkh. In scenario one, I'm asking you (the community) what to expect.  I've not yet come to a decomissioned server through this process but I do expect to. The process takes a while and I'm testing my first 'generation' of migrated tapes. Thanks!

pkh's picture

Once the server is decommissioned and there is no backup sets for this server, then it would be automatically removed from the BE console.

MusSeth's picture

if server is not showing up in beconsole, just add it with name it was backed up, it will add the server in beconsole ith the empty container, double click on the server name and than click restore to select the data.

flat file data can still be restored using the file redirection option,hope this helps.

surfnturf81's picture

I'm guessing you mean for scenarios 1 & 2 where I can install the agent to?  If I go through the wizard it appears there must be a live server to install an agent to.

MusSeth's picture

no the live server is not needed, this how we can restore data from the servers which have been decomssioned, we add in the server name, inventory and catalog the tape which has that servers data.

once inventory and catalog completes in backup exec 2012 under server name you would be able to see the backup sets and it should let you restore the data aswell.

surfnturf81's picture

I do not see how I can add a server that is not running. The "Add A Server" wizard requires a live server to install the agent to.  If BE has no knowledge of this server other than the migrated tapes backup sets, and I do not want to restore to this server (I just want the data), you are telling me this is the path I must go down?

pkh's picture

No. You do not add the decommissioned server. You are right in that you need a live server. See my article below on how you restore data from a decommissioned server

https://www-secure.symantec.com/connect/articles/b...

surfnturf81's picture

pkh thanks for the link, I imagine that will work and will use it when the time comes.

This I would say is the solution for scenario #1 I am looking for.

 

 

surfnturf81's picture

For non-decomissioned servers there is another issue that presents itself.  When I try to restore the old data that has been migrated from LTO2 to Disk to LTO5 for live servers, I go through the restore wizard, down to the date of the backup and select the files I'd like to restore, that whole process works fine but it choses to select the old LTO2 media for the restore, even when I point it to the new storage device (which I don't think is what that drop down is for).

How do I select the source to be my new LT05 tapes (or even the disk backup)?!?!

EDIT: I found this link: http://www.symantec.com/business/support/index?page=content&id=TECH186427

Wherein I should be provided with a "Where do you want to restore this data from?" wizard but I am not.  Again, this was a duplicate job to disk and then to the newer LTO5 tape so I would assume I've 3 choices but only the original LT02 tapes are given.

 

surfnturf81's picture

I was able to get the message to popup after deleting the old catalogs that the older backups used, recataloged the new LTO5 media, and I believe I had to wait for a DB maintenace cycle. 

Symantec tech support worked with me to identify a possible bug in this process and the work around is as I stated above.

He was able to get the 'restore from a different source' by the steps above with the exception of waiting for a db maintenance cycle. He did something else I didn't get written down and neither of us realized was required but after I repeated the cataloging processes and waited a day, the separate source was available.

They believe there to be a bug, as to why I have to remove the old catalog before the separate source window will occur. I was tasked to duplicate this process with separate media to confirm (I've plenty of archives I need to migrate).