Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Restore in BESR 8

Created: 12 Mar 2009 • Updated: 21 May 2010 | 5 comments

We purchased BESR for the purpose of being able to quickly restore to spare hardware or a virtual machine if the particular servers happened to crash, and I can only get it to restore to the same hardware that I backed it up from originally.  If I try to restore using Recover My Computer over the network or locally to identical or different hardware and a virtual environment, I get to the step that prompts for choosing a recovery point and my Drive and Target Drive both show as Invalid even though I can browse the images by using Recover My Files, and Recover My Computer will show the Drive and Target Drive correctly on the original hardware.

I've been through several boards which said that Restore Anyware was a part of BESR, but I have not seen any options that indicate that it is there.  For that matter there aren't any options for resizing partitions, etc...  Are additional licenses needed for this or is something wrong with my installation? 

I am using the BESR Prod and SRD CDs individually for the 8.0.3 version downloaded from my license manager site.  Standard install (keep clicking next until finished) and added our license once I signed in to the console.  I need to get this resolved for testing and actual recovery purposes.  What should I check?  What am I missing?

Comments 5 CommentsJump to latest comment

Bill Felt's picture

Hello,

Can you detail the steps you are taking in the Symantec Recovery Disk wizard?  Which recovery method are you selecting (e.g. filename, date, etc)?

Thanks.

marcogsp's picture

If you select by date, then the Restore AnyWare option option will not be available.  When restoring to dissimilar hardware, it is also a good idea to avoid selecting by system when working with different hardware..  Filename seems to work the best.  I haven't had too much luck restoring all the drives at once, so I do them individually.  As long as you don't choose the option to restart the system after restore, you can repeat drive recoveries as many times as needed in the same session.

MMazurkiewicz's picture

Here is what I'm trying to do.  I have created an empty virtual machine with 15 GB of space.  My BESR shows that I have a 8 GB C: Drive and a 170 MB D: Drive.  I boot the VM with the restore CD, map my share(have also attached the drive locally).

When I try to select the image I want to restore and that is where my problems start.  Restore by date and System gives me Invalid Drive and Target drive the partitions.  Restoring by filename gives me an ec95006 destination is not valid error.

I have successfully tested making the restore point of a different server and restoring it back to the same server, but I also can't restore that other one to any other hardware or virtual machine.  Since the server that I'm trying to perform this recovery simulation with is a production web server I can't sacrifice any down time to test restoring it back to the same hardware that I backed it up from.

This is why I'm trying to simulate what would be a bare metal recovery in case this server crashed and I had to restore it temporarily to a VM or different hardware, to document the process and get a real world estimate for the possible downtime before our website can be restored even if the original hardware is still having problems.

marcogsp's picture

Since you can browse to network and locally attached resources in the VM, that indicates that the VM is sharing resouces sucessfully with the host system.  If you can boot to some other media like BartPE or a Ghost boot disk, and format, read and write (copy resources from some other location than local) to the VM, that would further elimnate the VM environment as the cause

You mentioned that you were able to get a test system to restore to itself.  During the recovery process, there is information revealed about the image, which should include whether it is licensed for Restore Anyware.  Can you recall seeing this, or run through the motions again for this test system to verify?

It is like your licensed product is behaving like the trial version  The trial version will not allow the Restore Anyware option to work.  I'm not 100% positive, but I think images made with the trial version will not allow a Restore Anyware recovery, even if the product is later licensed.  If you could test another lab system in "trial" mode, and it produces the same symptoms, then possibly your licensed installation is behaving like a trial installation.

I once had another Symantec product that had a bad SLF file associated with it.  The SLF files have been abandoned in recent releases, which indicates that there were ongoing issues.  Anyway, I had to contact Symantec Licensing to get a new SLF file generated for my license.  Try downloading your SLF again.  If still no joy, then the  results of any testing mentioned above would cement your case for Symantec Licensing to generate a new SLF.

MMazurkiewicz's picture

Ends up our license file did not contain the Restore Anyware feature.  I worked with the folks at the license portal and got it resolved.