Video Screencast Help

restore by bprestore command fails with status 2826

Created: 29 Aug 2011 • Updated: 11 Dec 2011 | 2 comments
This issue has been solved. See solution.

Hey

I'm trying to restore a file from a Linux media server (local backup) to an HP-UX client to an alternate path

When restoring from the GUI, everything is fine

But when I try restoring by command it fails on status 2826 - unknown restore problem

 

the command:

bprestore -drs -t 0 -L /tmp/backup_seq_minhelet.log -R /tmp/backup_seq_minhelet.change -C drlinbck1 -D cellbck -s 08/28/2011 -w /PDSK4/ora_archive/archive/BACKUP_SEQUENCE_FILE.dat

 /tmp/backup_seq_minhelet.change  contains the line - change /PDSK4/ora_archive/archive to /tmp

the log reads

10:52:25 (9406081.001) INF - Beginning restore from server drlinbck1 to client cellbck.
10:52:26 (9406081.001) Unknown file type ''' for .SeCuRiTy.4, extracted as normal file
10:52:26 (9406081.001) /PDSK4/ora_archive/archive/BACKUP_SEQUENCE_FILE.dat
10:52:26 (9406081.001) Changed /PDSK4/ora_archive/archive/BACKUP_SEQUENCE_FILE.dat to /tmp/BACKUP_SEQUENCE_FILE.dat
10:52:26 (9406081.001) INF - TAR EXITING WITH STATUS = 0
10:52:26 (9406081.001) INF - TAR RESTORED 1 OF 2 FILES SUCCESSFULLY
10:52:26 (9406081.001) INF - TAR KEPT 0 EXISTING FILES
10:52:26 (9406081.001) INF - TAR PARTIALLY RESTORED 0 FILES

Has anyone seen this before?

 

Thanks

Comments 2 CommentsJump to latest comment

CRZ's picture

I believe that the .SeCuRiTy.4 file represents ACLs for the file in question and bpbkar is attempting to apply those ACLs on your HP-UX client, which is causing some trouble.  (Is this a restore to the same client, or an alternate client - and if an alternate client, are they different Operating Systems or perhaps extended ACLs are in use on one and not the other?)

Although...if it works from the GUI and not from the command line, there may be a bug somewhere.  Have you opened a case with us?  If not, can you?

(How much is it bugging YOU is probably the more salient question...assuming the restore file looks OK on your client - and I'm assuming it does? - you could probably get away with ignoring that error.  Just be sure to double check that the permissions on the restore file are acceptable to your legal team!)

SOLUTION
Harpreet Singh Chana's picture

Hi,

I have just upgraded my Master/media server to 7.1

I am also getting the same error during restore to another client with different OS.

<<

20:17:32 (52879.001) INF - TAR EXITING WITH STATUS = 0
20:17:32 (52879.001) INF - TAR RESTORED 2412303 OF 2412399 FILES SUCCESSFULLY
20:17:32 (52879.001) INF - TAR KEPT 0 EXISTING FILES
20:17:32 (52879.001) INF - TAR PARTIALLY RESTORED 0 FILES

20:17:32 (52879.001) Status of restore from copy 1 of image created Sun 01 Apr 2007 02:45:01 AM SGT = the restore failed to recover the requested files

20:17:32 (52879.xxx) INF - Status = invalid error number.>>

If it is related to ACLs. How we can list down the list of effected files.

Harpreet