Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Restore of data from exchange dag GRT backup fails

Created: 02 Nov 2012 • Updated: 02 Nov 2012 | 2 comments

Our setup for exchange is a cas array with 2 cas/bus servers and 2 mailbox servers in a dag, exchdag, with 2 databases running in vm's on server 2008 r2.

In a nutshell one of our users recieved a new iphone 5 and sync'd it to his outlook causing his contacts and calendar to be wiped. The servers are backed up full on friday with incrementals the rest of the work week. The exchange store is being backed up using the dag backup option and the data is available in the backup but fails every time i try to recover it. GRT is enabled.

I have tried restoring direct to the original location, redirect to the casarray, one of the individual cas servers, routing directly to mbx01 and trying to burn it to pst. 

Usually I log in as a standard domain admin on the backup server but I also tried logging in as the beservice account and this had no bearing on the outcome. outlook is installed on this machine fully patched as well.

The databases are available for overwrite restore options and the beservice account meets all of the administrative/permissions criteria. This is definately something specific to the exchange 2010 install, which is current with all updates, since we just recently upgraded from exchange 2007 and did not have an issue then. Of course before we only had a single box exchange server with all roles. 

The following is what I get when I try to restore to a pst, which seems a little fishy to me, which was pointed to c:\psts but for some reason is trying to route to \\localhost\Microsoft Information Store?

Comments 2 CommentsJump to latest comment

Jaydeep S's picture

What is the error message that you get on the restore job

Alex-Ru's picture

Same trouble. Redirect to .PST don't work. Writes \\servername\Microsoft Information store.  All time.