Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Restore DFS files from B2D to redirected folder is resulting in corrupt files

Created: 04 Jun 2013 | 7 comments

During a test restore of some test documents of my fileserver I discovered that 4 out of 22 documents (Word&Excel) seem to be corrupt after restore. At first I thought it was related to degraded tapes. My intial restore was from tape. No errors show up during backup or restore.

This morning I restored the same content but now from a B2D and discovered I had the same problem.
To not overwrite the original contents, I restored to a redirected folder.

My backup job makes a backup of a DFS share.
FileServer\Shadow Copy Components\User Data\Distributed File System Replication\DFS Share\Test Folder

I restored the following data
FileServer\User Data\Distributed File System Replication\DFS Share\Test Folder

My FileServer is a Windows 2008 R2 Storage Server and my media server is a Windows 2003 x32 Backup Exec 2010 R3 server.

Has anyone seen this behaviour before?

Remko

Operating Systems:

Comments 7 CommentsJump to latest comment

Remko de Koning's picture

Additional comment.

I did a test backup again of the same folder but now the share itself and not the DFS Share.
I am now able to open the documents without any problem.

Is there perhaps a specific setting that I need to take into account when backing up a DFS Share?

Also, it is not possible to backup the drive itself. During selection all content is shown on fileserver\D\Test Folder but on the actual backup there is no content stored.
I must say that making a backup of a DFS share is a bit of a mystery.

Remko

Colin Weaver's picture

DFS-R should be backed up using Shadow Copy Compnents.

Some customers backup via Windows shares of the file system (so not the DFS Shares) due to preferring that secondary method (performance, ease of restore etc)

 

 

Remko de Koning's picture

As said, creating a backup using Shadow Copy Components resulted in corrupted files during restore.
I am unsure why this happens. The backup and restore completes without errors

Remko

Remko de Koning's picture

I double checked today to confirm. I even tried creating a new backup job of my test folder.

Unfortunately same result.

Making a backup of the DFS share and then restore it (to a redirected folder) results in some corrupted files.
Making a backup of a regular share restores ok.

 

Very odd, I cannot put my finger on it.

 

Remko

Colin Weaver's picture

Please log a formal support case for Symantec to investigate