Video Screencast Help
Scheduled Maintenance: Symantec Connect is scheduled to be down Saturday, April 19 from 10am to 2pm Pacific Standard Time (GMT: 5pm to 9pm) for server migration and upgrades.
Please accept our apologies in advance for any inconvenience this might cause.

RESTORE: Directory Path

Created: 18 Nov 2009 • Updated: 21 May 2010 | 9 comments
This issue has been solved. See solution.

I am trying to restore an entire backup to a new location...

ORIGINAL path:
c:\userfiles\our_research\a bunch of subdirectories...etc...

INTENDED NEW LOCATION:
f:\a bunch of subdirectories...

PROBLEM: whenever I select the our_research folder it still restores to the following path:
f:\userfiles\our_research\a bunch of subdirectories...

how can I change this?

thanks...

Comments 9 CommentsJump to latest comment

CraigV's picture

In your restore job, where you select which data you'd like to restore too, you can choose to redirect your data to a specific folder. You can browse to it, or type it out.
Alternatively, you can create a B2D folder, and choose that as the media you'd like to restore too. However, disable the folder once done, as if your job isn't set up correctly, you'll end up backing up to that folder too.
I'd go with the first option though...

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

MSUTech's picture

I did a 'file redirection' and still got that problem...

[1]Selected RESTORE

[2]in selections -> View by Resource -> expanded server --> expanded c: ->  expanded date(Full) -> expanded userfiles folder -> checkmarked our_research folder (which partially marks C: & Userfiles);

[3]Selected 'File Redirection' -> checkmarked 'Redirect file sets';

[4]browsed within Restore to drive -> select F: on target server;

[5]hit Run now -> immediately within the F: (target server) it creates the full path: f:\userfiles\our_research\a bunch of folders and files

help?

Colin Weaver's picture

 I don't have Backup Exec in front of me right now - but in the properties of the restore job itself - I thought there was an option for "Preserve Tree" that you can disable that might do what you are after.

MSUTech's picture

I was thinking of trying that.. but, I thought that would lose the 'rest' of the sub-directories as well (dump everything in one folder)? Beneath the 'our_research' folder...?

CraigV's picture

Hi,

When you restore, it would restore the data/file/folder with the exact same folder structure.

So for example a temp.ppt file in F:\Public\Some Folder would be restored as: G:\Restored\Public\Some Folder\temp.ppt.

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Colin Weaver's picture

The preserve tree option won't remove all the folders within your directory structure - as otherwise there would be a major problem if the same file name existed in more than one of the folders you are restoring.

MSUTech's picture

I am testing this now and I will mark the response as the answer if it works...

MSUTech's picture

I removed the 'preserve tree' checkmark ... to try to have the restore do the following:

c:\userfiles\allofthepeople\staff\johnsmith

restore to:

f:\johnsmith

and it just dumped everything in the f: drive .... it created no subfolders and therefore skipped any redundant file names.....

so, is there a solution to my original problem?

Colin Weaver's picture

Hmm OK I just tested this as I do now have access to a BE server and I see the same as you i.e

1) With Preserve Tree checked - the redirect restore recreates the parent folders all the way to the root of the original volume.
2) Without  Preserve Tree checked - it just restores to flat files.

As such I don't think we can currently do exactly what you have aksed for which is restore the treee from the point of selection without the parent folders.

You might like to submit this as an Idea (via the Ideas section in the bar at the top of this forum) as then other customers can vote to give us an idea of demand.

 

SOLUTION