Video Screencast Help

Restore is done from the same media server from which the backup ran.

Created: 16 Nov 2012 • Updated: 18 Nov 2012 | 9 comments
This issue has been solved. See solution.

Restore is done from the same media server from which the backup ran.

 

Is this true in NBU 7.x?

 

Above is true till what version of NBU?

Comments 9 CommentsJump to latest comment

mph999's picture

By default yes, why would you think it would be anything else.
There are two ways i can think of that will change this - I will let you do some research to find out what they are, I will however give you some clues.

One way would affect all restores done by a media server and cause all of the restores to by 'run' by one other media server. This setting would be made in the bp.conf file, but can also be ser in the GUI.

The other way changes the media server entry for the fragment in the header file (image catalog). It can be made by running a command, and one of the 'options' you pass to this command is -oldserver.

Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Andy2345's picture

So below statement is true for all NBU versions?

 

Restore is done from the same media server from which the backup ran.

mph999's picture

I am not sure why when I give the answer, you ask the same question again... Yes

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Andy2345's picture

But we have 7.1 in our environment.But backup runs on other media server and restore is done frm other media server?

 

Why so?

mph999's picture

probably because you have a force_restore_media_server setting in bp.conf on the master (or registry if windows). 

if you did as i suggested and looked at the reasons nbu would not behave as default you would find this out for yourself.

Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Andy2345's picture

 

-bash-3.2$ cat bp.conf|grep -i force
-bash-3.2$ pwd
/usr/openv/netbackup
 
 
We dont have any such entry in bp.conf .
 
But restore runs from different media server from which the backup ran.
Marianne's picture

But we have 7.1 in our environment.But backup runs on other media server and restore is done frm other media server?

PLEASE always share ALL relevant details when you open a post. Such as the fact that you are using Data Domain with OST backups.

OST Restore behaviour is described in this TN: http://www.symantec.com/docs/TECH87200

Fixed by creating this touch-file on the master:
touch /usr/openv/netbackup/db/config/USE_BACKUP_MEDIA_SERVER_FOR_RESTORE

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
sazz.'s picture

I am using OST and my STU is any available media server, in these cases backup can go to any media server and so as the restore. If restore is working fine your job is done, don't make any changes which might corrupt the environment.