Video Screencast Help

Restore of Exchange GRT is successfull but mail object is not showing up!

Created: 09 Sep 2013 • Updated: 11 Sep 2013 | 7 comments
This issue has been solved. See solution.

I have a backup of Exchange 2010 Mailboxes with BE 2012.0.2 (Build 1798.1244)

I have installed the same Exchange 2010 Release / Mangement Tools (Build as on the Exchanger Server 2010.
I have all Backup Exec Updates and SP2 installed.
I have all WIndows Updates installed.

The Restore has been done with the same user account.
Backup Exec does a prestaging from LTO4 Tape to Disk an starts the restore of the Mail object from Disk.

Backup Exec log files states that restore is successful.
I select to overwrite the mail objects, i used the correct service logon account (with this one the backup was done).

I Redirected the restore to a new mailbox user with "zero" mails and only 2 notes.

The event log on the media server and the exchange server doesn´t show any sign of errors.

I tried to restore an importan note.

Even the usermail box a mail from symantec backup, telling him that some object have been restored. ...

But there is no sign of these object at all.

Can anyone from the forum users help?

AND: NO i don´t have a support contract for a programm not supporting Windows 2012 as an underlying OS. BE runs on Windows 2008 R2 Std.



Operating Systems:

Comments 7 CommentsJump to latest comment

Donald Eady's picture

I know that you have confirmed that the management tools match the exchange build but if you would please follow the testing detailed in the following document and report the results

1. Duplicate the data from tape to disk (if the data is on tape).
2. Attempt to restore the data from disk after putting the restore operation in debug mode.
3. Look for the following error in the debug logs:
-514 The version of the log file is not compatible with the ESE version

I hope this posting was helpful


JuergenB's picture


i did a quick check and viewed the details of ese.dll with explorer (properties)


The Exchange release seems to be no public release.
So the version is different. Windows Update only show Exchange 2010 SP3, with no rollup package.
But window update will install Exchange 2010 SP3 update rollup 2

These are the official build, but where do i get a release?

2010SP3 12. Feb 2013
2010SP3UR1 29. Mai 2013
2010SP3UR2 13. Aug 2013

I did a test with the wrong releases (right now)...

On my personal mailbox the mail object (simple note) was not restored at all.
At a second mailbox the object (simpel note and 2 mails) where restored fine.

But a note that i redirected to the second mailbox is still not restored at all.

I will install this update on the media server and try again.


Donald Eady's picture

Ok... Please update once you have had the opportunity to install the update on the media and reattempt the restore

I hope this posting was helpful


JuergenB's picture


i did a Update of Exchange 2010 SP3 Rollup 2 on both servers.

I was able to restore all mail box items to the original source (restore to the same mailbox account).

On the second test acount (User B), backup exec created a duplicate item of a note.
I forgot to delete the note on this mailbox, and it should not overwrite it (i think so).
But it´s duplicated now (Same content, same display).

One item still doesn´t get restored. It´s an item from Mailbox "User A" and i wanted to redirect it to Mailbox "User B" (a outlook note with some notes in it).

This still doesn´t work.

So Backup Exec seems to

  • create duplicate notes
  • doesn´t like to restore mailbox notes to a different mailbox account

I will try to run this with debug on tommorow.

JuergenB's picture


so i updated both, the server and the media server.

I enabled debuging on exchange and media server.
The restore of a mailbox item of User A (notes) is not possible to a different mailbox User B.

It simply doesn´t show up in the target mailbox.
And the loggins show no error ...

The workaround is not working at all

Workaround for Old Backup Sets:
Duplicate data from tape to disk 

Any idea now?

JuergenB's picture

Hello Imosla,

I tried a GRT restore of the single mail object to a PST File.
I restored the PST to our Windows Terminal Server (BE Agent and Outlook 2010 installed).

I was able to open the pst file now with Outlook 2010 and could restore the data successfully.

Thanks for the informaton and help.

But i think there is still a problem with GRT restore to a different Mailbox User.
Maybe it´s somethink about security and acl.

I am in contact with Donal from symantec.