Video Screencast Help
Scheduled Maintenance: Symantec Connect is scheduled to be down Saturday, April 19 from 10am to 2pm Pacific Standard Time (GMT: 5pm to 9pm) for server migration and upgrades.
Please accept our apologies in advance for any inconvenience this might cause.

Restore failed ( error 85 ) , but bpmedialist works

Created: 29 Jan 2013 • Updated: 23 Mar 2013 | 8 comments
This issue has been solved. See solution.

Hi.

I have two IBM TS3500 Libraries with LTO/5 Drives running.

My Master runs on Solaris 10 and my Media Servers runs on Redhat REL5. ( NBU 7.1.0.4 )

After a RMAN Oracle restore i got a read error message. After that i tried to read the IMAGE with bpduplicate & bpverify. All of this tries failed!

See:

bpduplicate -cn 2 -dstunit Staging_Migration -backupid SERVER-16_1359155089

Duplicate started Tue Jan 29 10:55:44 2013

Activity monitor job id = 1245924

INF - Skipping copy 1 of backup id SERVER-16_1359155089, is not required copy 2.

INF - Destination storage unit Staging_Migration on host MEDIA-SERVER

INF - Duplicating policy RMAN_xxx schedule Default-Application-Backup backup id SERVER-16_1359155089 copy 2 created on 01/26/2013 00:04:49 on source media id 061003

INF - host MEDIA-SERVER backup id SERVER-16_1359155089 read failed, media read error (85).

INF - host MEDIA-SERVER backupid SERVER-16_1359155089 write failed, media manager killed by signal (82).

INF - Duplicate of backupid SERVER-16_1359155089 failed, media manager killed by signal (82).

INF - Status = no images were successfully processed.

 

But a bpmedialist can find the IMAGE on TAPE

bpmedialist -mcontents -m 061003 –L

…shows…

backup_id = SERVER-16_1359155089, version = 2

creation = 01/26/2013 00:04:49 (1359155089)

expiration = 04/29/2013 01:04:49 (1367190289)

retention_level = 3, fragment = 1, file_num = 229

block_size = 1048576, status = 0x0

media_id = 061003, size = 0, data_start = 610731

client_type = 4, copy_num = 2

sched_type = 2, flags = 0x80

policy = RMAN_Produktion

sched_label = Default-Application-Backup

opt_extra = 0, mpx_headers = 6, res1 = 0

 

Can anybody give me the reason why?

And I tested much ORACLE RMAn Backup Tapes and very much Tapes have read errors. Backup from other policies do not have any read errors!

 

 

 

 

 

 

Comments 8 CommentsJump to latest comment

Nagalla's picture

hi,

bpimagelist will look for the info in image database located in Master server /usr/openv/netbackup/db/images.

but the bpduplicate , and bpverify commands reads the actaul data located in Tape.

as your are getting error whey you try to duplicate  and verify the data, possibly it might be with the bad tape some time may be becaue of Tape Drive

how your other tapes reading?

 

you would need to check few things before you make sure that the tape is bad.

1) try to read the tape with Dirrerent Tape Drive.

2) try tape Drive cleaning and after that try to read the data.

if the tape is bad, you have only option to replace the tape.

how old your Tapes are ? did check check if they are corssed the  recommented limt of usage?

 

Thomas Schulz 3's picture

Hi.

I'm sure that the bpmedialist read from the tape, because the netbackup system mounts the tape an read it.

And Yes, a bpimagelist do not read from tape, but i do not talk about a "bpimagelist"

The Tapes are 2 years old and the IBM Library cleans the drives automaticly

Nagalla's picture

yah, i guess i misread it, yes, bpmedialist reads the content of the tape, but not entire data as Marianne said.

Marianne's picture

bpmedialist -mcontents (media contents report) will just report backup header information on the disk image. It will not check and verify all data on disk. bpverify may do this for you...

To troubleshoot status 85, ensure that bptm and bpdm logs are enabled on the media server.
Check if device-level errors are logged in /var/log/messages.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Mark_Solutions's picture

How large is this image?

There was an issue i read about once where the paged memory usage for a very large restore exhausted the capabilities of the Media Server.

Worth checking the Media Servers logs (O/S logs / messages) to see if it is struggling - I cannot see from yoru log extracts how long it is before it fails.

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Nicolai's picture

As status 85 is a media read error. Please check dmesg or messages/syslog file for SCSI related error messages. Especially SCSI sense information.

Verify the firmware on the tape drives are updated.

 

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

SOLUTION
Thomas Schulz 3's picture

Hello.

I've a call by IBM to downgrade the LTO firmware to the last working version.

I hope it will fix my problem.

Thomas Schulz 3's picture

Today we downgraded the IBM LTO/5 Firmware and it works.

Thank you very much for your help.