Video Screencast Help

Restore fails

Created: 23 Jul 2013 | 17 comments

Hi People,

I have backups running to tape and disk-to-folder each evening.

Backup Exec 12.5

On Microsoft Windows Server 2008 Standard Edition, 64-bit

These appear to be working OK but i am now attempting to restore a mailbox and i receive the following message:

Job ended: 23 July 2013 at 13:56:21
Completed status: Failed
Final error: 0xe000848c - Unable to attach to a resource.  Make sure that all selected resources exist and are online, and then try again.  If the server or resource no longer exists, remove it from the selection list. Edit the selection list properties, click the View Selection Details tab, and then remove the resource.
Final error category: Resource Errors
For additional information regarding this error refer to link V-79-57344-33932
I have been through all the articles that link refers to with no success.
I have been able to carry out a simple file restore from the the folder that I am putting backups into so I am happy that the server can get access to the area in question.  However, when I attempt to restore anything regarding mailboxes nothing works.
I also ran a debug and got:
Error 10: Invalid device
Any ideas would be appreciated because once again, symantec has failed to live up to expectations.
Operating Systems:

Comments 17 CommentsJump to latest comment

Jaydeep S's picture

Does this happen on restores from both disk and tape? Unsure what is the version of Exchange that you are using. Could you confirm if the below 3 accounts have an active mailbox which is not hidden from the Exchange Address list.

1. Backup Exec System Logon Account.

2. Account used for the restore

3. Backup Exec Service Logon account

Ensure that the remote agent on the Exchange Server is fully patched. Also check if any permissions have changed recently. Ensure that all permissions mentioned in this Technote are granted.

ZeRoC00L's picture

Do you have the Exchange management tools installed on the Backup Exec Media server ?

Same version is requied as on the Exchange server.

If this response answers your concern, please mark it as a "solution"

MusSeth's picture

In addition to what jaydeep said ...Logon account needs to be member of exchange full administrator for exchange 2003 and exchange organization administrator for 2007 apart from this account needs member of administrators and domain admin group as well...

CraigV's picture

...I guess the question to ask is what version of Exchange are you running...?

This dictates whether or not you need the Exchange management tools installed.


Alternative ways to access Backup Exec Technical Support:

wedmonds's picture

Thanks for coming back.

Essentially there are a number of things that could be wrong as support for the server has been inherited.

Therefore I am happy to look into any suggestions although i may need some guidance in places.

We have a singl Exchange Server with Backup Exec 12.5 installed onto a Win 2008 server.

We have a standard 2008 server elsewhere on the network that we backup to.

What Version of Exchange

We are running Exchange 2007

Does it happen with tape of folder
We have struggled to get tape backups working with the exchange store.  The services stop or the backup stops middway through backup to tape hence why we moved away from the tape.  The tape drive is also old and so are the tapes so we thought it was worth outputting to a folder to eliniate the tape drive.
This appears to work as we were able to get backups to folder each evening.

Exchange Tools
We dont have any additional software installed on the server we are taking backups to.  Could this be the problem?

Active Mailboxes
I previously created a "symantecbackup" user that we setup as admin and carry out backups as.
This user also has a mailbox that is visible and is not hidden from address book.

Are there some simple test that I can carry out in order to prove permissions are correct across the board?

Can the debug information not tell us the problem?

Jaydeep S's picture
Ensure all the requirements mentioned below are met :
1. Backup Exec Account used for backup must have an active mailbox on the exchange server.
2. The mailbox should not be hidden from the Global Address List
3. The account is a Domain Admin and must be added to Exchange Organization Administrators and Exchange Server Administrators groups
4. Backup Exec "Logon Account" is an explicit member of Local Administrators group in the Exchange Server
5. Backup Exec "Logon Account" is "Unique" inside the Exchange Organization.  See  "How to confirm that an Exchange mailbox name is unique within the Exchange organization when configuring Backup Exec to back up Exchange mailboxes"
6. Microsoft Exchange Server MAPI Client and Collaboration Data Objects is installed in the Exchange 2007 Server.
7. Exchange 2007 Management Tools are installed in the Media Server and updated
If the Media server is 64 bit it can be installed from the Exchange 2007 Installation Media. If Media Server is 32 bits use this link -

wedmonds's picture
OK, I am happy with Points 1 -6 which leaves point 7.
I have inserted the DVD and run it but it jumps straight to point 4 and looks like its going to install exchange again so I am reluctant to go any further.  Is there not a straight download for 64 bit?
Am i correct in saying that a Media Server is any box you are backing up to?
I am sorry but i dont understand what you are asking?
I am not backing up to cloud.
MusSeth's picture

Wed I read it wrong in the above post...however can you try redirected restore to same mailbox or to different one..see if the issue persist there or not...another thing is to keep backup exec service account and logon account same...hope this helps...apologize for wrong comment again...

wedmonds's picture

Exchange 2007 Management Tools were already installed on the server.

They were not installed on the media server (the box we are attempting to restore from).
However, I have now installed these.

What are the next steps?

wedmonds's picture

I am not able to restore any mailboxes.

This includes administrator.

I just get an instant failure within 7 seconds.  Does this tell us anything?

MusSeth's picture

Could you please run credential test in selection list and check if it is successful there..make sure the account is configures like windows format domain\username in backup exec....

wedmonds's picture

Yes tried that a number of times.
I have just did again however and confirm that it passed its test and that the domain\username is set correctly.

Surely the error has to be output in a log somewhere?  

Jaydeep S's picture

It is better if you open a case with Technical Support. There might be some detailed logging which might have to be enabled and analyzed.

MusSeth's picture

Is windows firewall enabled on exchange you have any antivirus running on the server ...disable it and than try with a restore

wedmonds's picture

I doubt it would be the firewall as I am able to restore files.
i went ahead and tried it none the less and it still failed.

The key has to be :

1. I can restore files but not anything to do with mailboxes.

2. There are error log files generated.  Surely these tell you guys something?  They are defined by Symantec so what do they mean?

I do appreciate all your help.

wedmonds's picture

OK have raised a ticket but just came across something else which may be a possible cause.

I went into Exchange Management Console and under Disconnected Mailboxes it says:

Warning: The databse 'servername\Recovery Storage Group\Mailbox Database to be accessed on server 'servername.domain.local' is not mounted or is not available.

Is this related to restores?  Sounds like it is.

Also I just tried another backup of exchange and it failed after around 10 minutes with an error message:

e000ff02 - One or more of the databases for this storage group are currently dismounted.  This backup is incomplete.  Make sure that all databases are mounted, and then resubmit the backup job.
For additional information regarding this error refer to link V-79-57344-65282

Did not do this before.

Does this shine any light on the issue?

MusSeth's picture

The databse 'servername\Recovery Storage Group\Mailbox Database

please remove the recovety storage group from the exchange server if you are done with extracting mailbox or task for which it was created and than retry with the backup job

if backup works try with a restore

technet article might be helpful in getting it safely removed.