Video Screencast Help

Restore to NetWare 6.5/OES

Created: 18 Jun 2013 • Updated: 21 Jun 2013 | 3 comments
This issue has been solved. See solution.

Tasked with restoring an old GroupWise server to gain access to old emails. Complete NetWare noob, and IT from back in the day is long gone. GroupWise 7 was running on NetWare 6.5 OES. We have the software disks for NW and GW.

I've duplicated what I understand the old setup to be:

  • A WS2003 box running BE 11d and Novell client for Windows and a DLT tape drive
  • A NW 6.5 OES box with BE Remote Agent for NW using TCP/IP and host name registered in DNS and resolvable by NetBIOS name or FQDN by the Windows box

I've inventoried and cataloged the DLT tapes to the BE database and can browse the files and folders that were backed up. I can also browse the remote NW server from the WS box without any problem, using the default NetWare "admin" account.

I've verified RANW is running by using TELNET NETWARESERVERNAME 10000 from the Windows box. A connection is made.

Remote Agent authentication is my current problem.

For resource credentials, BE uses the same "admin" account as I'm successfully using with the NetWare Client. I've created a local Windows account named "admin" and am using that as the interactive user account and the BE service credentials. The NetWare "admin" account is set as the Default Account in the NetWare client for Windows. My limited understanding of NetWare is that this "admin" account is as fully priveleged as is "Administrator" in the Windows world.

If I use "admin" as the Default Logon Account username, and click Test All in Resource Credentials for a Restore, it says "Access is denied." under Test Results.

http://www.symantec.com/docs/TECH83381 suggests a number of things, all of which I've tried. Among them, it says to use .Username.Context format, but when I enter that, I get this message as soon as I click Test All: "Your default logon account could not be authenticated. The username or password may be incorrect. Click OK to edit your default logon account." When I click OK, I'm presented with the Edit Logon Credentials dialog. I've also tried ".admin" and ".admin.context.tree" with the same results. Only way I've found to get that dialog box to close is to revert to "admin".

http://www.symantec.com/docs/TECH56917 says the "Access is denied" result is a bug that may be fixed in a future version of BE. (If so, I have 11d server & agent fully patched, and the bug was never fixed!)

With it set to "admin" and disregarding the credentials test per TECH56917, if I try to do a test restore to the NW server, I get this in the Job Log:

In the Restore section, "Access is denied to Remote Agent"

In the Job Completion Status: "Final error: 0xe000fe29 - Authentication failed on connection to the server. Make sure that the user account has the appropriate permissions and that the password was typed correctly. Final error category: Security Errors. For additional information regarding this error refer to link V-79-57344-65065.

A test backup goes the same way; I can select the resources for backup and create the Job, but it fails, with the same entries in the Job Log.

So...anyone out there still know how to set logon credentials for a restore job against a RANW machine?

Operating Systems:

Comments 3 CommentsJump to latest comment

JRV2's picture

Disregard...content merged in to original post.

Jaydeep S's picture

Make the following changes.

1. System Logon Account - use a windows admin account (domainname\Username format) and set this as default.

2. Add a Netware account, give any name - The user name here is the netware admin account (.admin.context format).

When you create the restore job, go to resource credentials tab and use the second account. This should now work and allow you to restore the data. If you still face any issues, report here and/or hit me on twitter @js3012

Note: No matter what the test credentials are, run the job it will work.

SOLUTION
JRV2's picture

Thanks JayDeep

I know I tried that combination, but probably never tried actually doing a backup with it! 4% into a restore now, so I think this did the trick.