Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Restore - no entity found

Created: 17 Dec 2012 • Updated: 07 May 2014 | 25 comments
This issue has been solved. See solution.

Morning all,

I'm trying to restore a few items but we're getting the error "no entity found" while browsing within the Java BAR console.

If I try to do the same within the Windows console on the master server directly, I can see all the folders and files without issue.

The Master server is running 7.5.0.1 (Java installed as well) as is my PC.

I can navigate some of the folders with the Java console but then get the "no entity found" error on other folders.

If I try to navigate the same folders which gave me the error but this time directly from the master server it then shows them and even allows me to drill down further.

I loged onto the master server with the same credentails as I do with the Java console on my PC.

Obviously as I can access the master server and restore from there it's not a mojor problem but we have a team which run with restore requests and they wouldn't have direct access to the master server, leaving them with no option but to use the JAVA console and therefore no way to restore these files.

Has anyone seen anything like this before ?

Regards

Kevin

Comments 25 CommentsJump to latest comment

RamNagalla's picture

hey,

when you login from Java console, are you using the same name how netbackup conifigured .you can check that form bpgetconfig.

or using the IP address or different name(its possible when server have multiple IP address)

how its working when you driectly open the Java console from Netbackup Master server ?(not netbackup admin console)

Kevin O'Connor's picture

Hi,

Yep, using the same name as is configured and confirmed with bpgetconfig.

I only get the error when using the java BAR console, either from my PC or the master server, I can only navigate all of the folder structure when using the Admin console (nbwin.exe).

RamNagalla's picture

Hi,

did you identify how much time its taking before giving the error "no entity found"

try to chage the setting as below and see how it works.. 

On the Java Remote Administration Console machine edit the install_path\VERITAS\Java\setconf.bat as follows:

Modify this default setting.
 SET NBJAVA_CORBA_DEFAULT_TIMEOUT=60

 Change it to:
 SET NBJAVA_CORBA_DEFAULT_TIMEOUT=300

 After this setting is changed can you open the java console and attempt to list ..

hope this helps.. 

Kevin O'Connor's picture

Hi,

Unfortunately it's an instant error, there's no delay as if it's having trouble searching for it.

I did reset it to 300 from the default of 60 but no joy.

Thanks for the suggestion though.

Nicolai's picture

Is the master server same OS as client ?

You may need to set the policy type in the GUI. UNIX boxes uses standart while Windows hosts use type MS-Windows.

Else check FQDN - Server host1 and host1.acme.com is not the same in Netbackup terms.

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

Kevin O'Connor's picture

Yep both are running Windows 2008 R2 x64.

There's no problem connecting to the client, the problem occurs while trying to navigate the backup structure to chose which files to restore.

Nicolai's picture

Do you get a list of backup and then the display of files fails ?

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

Kevin O'Connor's picture

I get a list of folders and files but when I try to look into specific folders I get the error, the problem is using the same logon detials etc but using the Admin console (NBConsole.EXE) I can get access to the same folders and no error so it looks to be an issue with the Java console.

RamNagalla's picture

the possible guess , that i can do is..

1) timeout.

2) java is not getting proper authentication in time

unfrotunatly i dont have any think to prove it..

Kevin O'Connor's picture

Thanks for the help but I don't think its a timeout issue, I've already increased the timeout value but that didn't work.

Also, the fact I can have access to some of the folders and not others while in the Java console and full access within the Admion console I think it's a java issue.

RamNagalla's picture

May be time for support call.. 

Kevin O'Connor's picture

Ya we've opened a call this morning, thanks for your help on this.

I'll keep this open and if we get it resolved before christmas I'll post the resolution here.

Marianne's picture

I don't have a quick solution, just a way to troubleshoot.

Ensure bprd log folder exists on the master server. If not, create the folder under ...\netbackup\logs, followed by restart of NBU Request Service.

Do a successful browse of folders on Windows Admin Console.
Attempt the same browse from Java Console.

Compare the entries in bprd log - there is bound to be a difference...

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

C_Moisan's picture

Are the folders that are giving you trouble containing names with accented characters suchs as à é è, etc...? We are having a similar problem on our side. I get a "no entity found" message as soon as I select those folders for restore in the Java console. The thing is, it's doing it only if I have version 7.05.04... Our master server is still on 7.05.03 and we will do a test if it's fixed when we upgrade it to 7.05.04. I opened a case with Symantec too and will post the results here if we find a sollution.

Christian.

quebek's picture

I do concur with C_Moisan - I have an opened case in the same regards...

Alos you may want to review this thread - https://www-secure.symantec.com/connect/forums/nbu...

C_Moisan's picture

Here's an image that shows what I mean:

The console on the left is not displaying accents correctly but it's the one that works fine... It's running from our master server and it's 7.05.03. The image on the right is displaying accents correctly but it's the one giving out the "no entity found" message as soon as you select a folder name with an accented character in it. It's running from my PC and it's version 7.05.04.

Marianne's picture

Hopefully all of you experiencing this problem have interchanged Symantec case #'s and passed it on to your respective Support engineers? And asked for call to be escalated?

I'm curious to know the outcome...

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

C_Moisan's picture

I haven't asked this to be escalated yet because not much has been done so far, they weren't able to reproduce the issue but there might have been some confusion about the issue itself...

Kevin O'Connor's picture

Sorry I haven't responed before now.

In the end I opened a call and pushed them but the only suggestion was to upgrade the java to 7.5.0.4.
I prefer to keep everything on the same version but I gave it a try and sure enough it resolved the problem.

I only had to upgrade the java console not the client, media or master.

SOLUTION
C_Moisan's picture

I don't understand why it works for you. For me, the problem happens ONLY if I'm using Java 7.05.04. With 7.05.03 it works fine. Can you confirm 100% that you can select folders with accented characters fine in 7.05.04? For me, as soon as I select one of those, I get the no entity error...

C_Moisan's picture

The support guys have been able to reproduce the issue. They are testing some proposed fixes and will get back to me. I will update this thread when I can.

Benoit Cote's picture

Hi Everyone,

i also just opened a case with my Symantec Engineer concerning this issue. I am already running 7.5.0.4 on RHEL and my Windows Java Console on my PC is already at the latest version and indeed, every folder that has accents in them like mentioned by C_Moisan gives me a ''No entity found'' error upon cliking them.

I am hoping for all of us that there can be a quick fix.

I will also post back if me or the engineer figure out what is causing this issue.

Thanks,

Benoit

C_Moisan's picture

Good news! The engineers found a fix for that. It was Benoit Cote who told me. Please ask your respective engineers to check case 03835177 for the fix. The display for accents is still messed up but at least it doesn't give the "no entity found" error anymore.

JJUt's picture

Found in another post.  Upgrade to java client 7.5.0.4 seems to solve probelm so far.

Benoit Cote's picture

Hi JJUt,

I had to dig deep in my email to find the case I had for this issue but I found a .jar file that my engineer had given me to fix this problem. It is possible that the upgrade to 7.5.0.4 worked for you, but if you still are experiencing restore issues in the future, simply post here again and I will get in touch with you and see how we can move from there.

Cheers,

Benoit