Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Restore from SDR on a remote server won't work

Created: 18 Jun 2013 | 12 comments

Hello,

I come here again, because I'm proceeding my bunch of tests. Currently, I try to restore my main domain controller (Active Directory + DHCP + DNS) on a remote server.

The two servers are from Dell brand, physical.

The disk configuration "appear" to be the same (not the case apparently), but the system reserved and OEM partitions are recognized as incompatible, the size is ok.

comp_disk.png

*For the OEM, I've created a RAW partition instead of NTFS

  • The system reserved partition is recognized as System, but not Active, when I boot on the SDR disk
  • The OEM Dell Partition can't be manually created I think, I just need to the right file format I guess.

But my question, is why the System Reserved 100 Mb partition is not compatible ? I mean, it's the same both side !

Thanks in advance,

Regards,

Alex

Operating Systems:

Comments 12 CommentsJump to latest comment

Jaydeep S's picture

When performing SDR wizard, have you tried to reconfigure all the partitions again using the wizard.

Alex-NeoIT's picture

Yes I tried the whole possibilities from the diskpart utility available in the SDR wizard. Delete, extend, reduce, mark as "OEM Partition" ... only the C: drive is displayed compatible for a restore.

Jaydeep S's picture

Have you attempted to proceed with the restore on C drive. If yes, what were the results.

Alex-NeoIT's picture

I can't restore anything since one or more of my partitions aren't compatible. If you mean restore from BE server the C: drive only, I think it worth a try.

Alex-NeoIT's picture

So, I sucessfully restored the C: drive, ... that led to corrupt my Windows, and I wasn't able to boot, either on Active Directory revcovery mode, normal mode or fail safe mode.

I would like to understand something, if you don't mind :

Let's say I don't want to use the SDR anymore, and I want to restore my AD backup on a remote server, the briefs steps in order to make it, would be the following (please correct me if I'm wrong somewhere) :

On the remote computer, I have to install the RAWS, etablish a trust link between BE and the remote server, NOT install AD services. Then check if partitions are the same as the ones I want to restore ( >= capacity and same filesystem)

On the backup exec server, I have to restore the C: first, restoring over existing files, preserving tree and security. Then, when it's done, (I have a bluescreen to the reboot at this point, so it's obviously a bad practice.), I have to reboot in AD recovery mode, and then make a system state recovery.

I've seen some guy restoring both System state + C: drive on a video, I'm unable to do this, I can only select one of the two options.

Thanks a lot, I'm struggling with this for a week.

Alex-NeoIT's picture

Hello,

I'm a bit upset right now ... Even opening a technical case and talking with a technician, didn't changed anything. Pay around 8500$ for a software that can't restore an Active Directory on another server is a pity.

Let's say we can't restore this one. I've tried SDR solution, restoring in 2 different jobs from BE, manually recreating the Dell partition (it worked, but BE didn't recognized it as an OEM Partition, even if Windows have shown at the disk 0, partition 1, the OEM Partition (exactly the same as the one which is on my origin server). I know it's the same partition because I've edited this one to a very low level (seen the same type (DE), cylinders, same heads, sectors ...).

SO, I started from scratch, again.

  • Reinstalled a new Win2k8 R2 Server, promote it as an AD, nammed it "SRV-DCTEST"
  • There is only 2 partitions to backup in order to activate the SDR feature : Reserved for system (100Mb) and C:\ drive.
  • Created some fake OUs, security groups, users ...
  • Joined a client machine to this domain, it worked.
  • I've made a complete SDR backup of my SRV-DCTEST
  • Created a VM with brand new Win2k8 R2 Server
  • Installed the Remote Agent on a different partition than C:
  • Modifyied the name to match with the SRV-DCTEST.
  • Checked the 100 Mb reserved partition was here, and checked I had free space enough to restore C:\
  • Made a backup of this server (in order to generate the ".DR" file for this server)
  • Created a SDR .iso of it.
  • Booted my virtual server with the SDR .iso, followed the steps without errors and then ...

My reserved system 100 mb partitions wasn't corresponding.

The one of my remote virtual server, marked as "Active" and assigned a letter.

The one of my physical server, marked as "Active" and "System" without any letter.

I tried to change or delete the letter on the remote server partition, but it didn't changed anything, it wasn't matching again.

Colin Weaver's picture

If you opened a support case then keep working with that technician and possibly even ask if it can be escalated to the next level.

Gut feeling is this is either because of the original partition layout (with OEM partition sitting before the system reserved one), OR an odd effect related to installing our agent into a drive other than C: (which is supported, just very very few customers do this)

Alex-NeoIT's picture

Hi Colin,

I've tried first with the agent on C:\ drive but a technician advised me to install it on a data partition, as it could disturb the restore.

here is some pictures to embroider and provide more details :

It's not about an OEM partition right now, as my 2 test servers were installed without any utilitary, but with a raw windows .iso. The impossible step :

be_2_cmp.png

And, here is when I remove the letter assigned :

be_1_cmp.png

Jaydeep S's picture

I was digging a bit more on this and while discussing it with your assigned technician to work on the case stumbled upon

https://www-secure.symantec.com/connect/forums/be-sdr-disk-wont-boot-efi-mode#/comment-8858551

Are you using a UEFI based physical server? If yes, you would need a UEFI based server to be able to restore to. Hope you are doing this and getting the errors.

http://www.symantec.com/docs/HOWTO74439

Alex-NeoIT's picture

Just to avoid confusions, the topic I've made, was about another restore test.

Not on the same server, as this one, have MBR partitions, and then wasn't installed in UEFI mode, but with the BIOS.

Jaydeep S's picture

Perfect, I have updated the technician on the case about this and he will proceed with the required investigation.

Alex-NeoIT's picture

It worked with a VM under HyperV.

I manage to recreate an environment which could host a restore of my physical DC.

I ticked "Erase the hard drives ..." checkbox under the quick view of the partition of the server / the backup (like the picture of a post by me, upper) and the SDR utility was able to delete/format the partition in order to match with the backup I want to restore.

I've done the same thing as I've done with my physical server to restore. I guess a VM is more "flexible" than a physical machine.

Anyway, I got my answer, but not to restore on a physical server yet. But I thinks it's enough and I spent way too much time than I would normally have to spent.

Thanks for the support