Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

restoreshortcutbody process interupted do i need to restart or will it do it by itself

Created: 05 Jan 2013 • Updated: 15 Jan 2013 | 3 comments
This issue has been solved. See solution.

hi

i ran the shortcutbody process (evault 10 sp1, exchange 2010 sp2 ru3) against 7 email archives but the exchange mailbox server became unavailable (information store service crashed) after about 9 hours.

the process stopped. with this event id 3310

There was a problem accessing a network service or resource.  The dispenser will re-queue the current item and sleep for 10 minute(s).

Task: Exchange Mailbox Archiving Task for UK-MAILBOX00
Internal Reference: Network connectivity issues (MAPI_E_LOGON_FAILED)

the exchange server is now up and running again (was down for about 1 hour) but the task does not seem to have resumed (am monitoring it via a search folder)

i have restarted the evault server but still nothing

from monitoring the shortcutbody restore process had finished running on 5 archives and on 2 there is still about 50% left to do.

i don't want to restart the process on those 2 archives again if i can help it as they have 100k items in it creating large log files on the exchange server

will the task continue at some stage or is restarting the only option?

cheers

Comments 3 CommentsJump to latest comment

AndrewB's picture

does the task status say running or processing? if it says running then you need to start it again. if it says processing then it should be doing its thing.

Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner | www.trace3.com

JesusWept3's picture

Fwiw with restoreshortcutbody and things like deleteemptyfolders, there are no checkpoints, so if a task restarts or the server reboots etc, it starts from the very beginning and what ends up happening is it will reprocess all the mailboxes and all the items already processed

So it may not look like its doing anything but its because its just re-doing the work it had already done

SOLUTION
elbutre's picture

i have been monitoring the 8 mailboxes using the search folder method in outlook (modified date) and no more shortcuts have been processes since the enterprise vault server lost communication with the exchange server (saturday morning) so it has been a full 2 days without any further changes.

as it had processed 6 out of the 8 mailboxes fully, i will change registry setting back to 0, restart services and then change it back to 1 again and run it against the 2 partly configured mailboxes.

we only run archiving tasks on a once per week schedule (thursdays) so this will give me some time to complete this process)

btw tasks says running.

time to upgrade to SP2 as i think it has better monitoring....