Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Restoring Exchange 2007 IS/mailboxes failing

Created: 29 Jun 2012 • Updated: 17 Jul 2012 | 4 comments
This issue has been solved. See solution.

Hello,

I'm having a problem restoring a complete database or single mailbox on BackupExec 11d + Exchange 2007. The backup is of the complete information store and is being restored to the same server (it's simply verifying if our Exchange backups can be restored in case of a disaster). The BackupExec engine and Exchange IS are on different servers (the Exchange server has the agent running).

I've tried two things:

1. Restore a mailbox (my own) to a different account (test) using mailbox redirection. When I do this, the job starts running, stuff appears in the TEMP directory that looks like transaction logs so something is happening, the job is completed successfully, but no mail appears in the test account's mailbox.

2. Restore the entire mailbox database to a RSG (which is fresh and dismounted at the time of restore). When I do this, I get the "Unable to attach to a resource. Make sure that all selected resources exist and are online, and then try again" error immediately. I've seen this is a fairly common error and is related to differently named storage groups/databases in the backup and server restoring to (http://www.symantec.com/business/support/index?page=content&id=TECH130017), but in my case, it's the same server! Debug log says this:

[5136] 06/29/12 15:17:50   AD:Device (\\exchangeserver.company.local\Microsoft Information Store\<+!RSG!+>) is not ours...
[5136] 06/29/12 15:17:50   30 = 0xE00084AF
[5136] 06/29/12 15:17:50   31 = 0xE00084AF
[5136] 06/29/12 15:17:50   35 = 0xE00084AF
[5136] 06/29/12 15:17:50   36 = 0xE00084AF
[5136] 06/29/12 15:17:50    5 = 0xE000FE23
[5136] 06/29/12 15:17:50    7 = 0xE000FE23
[5136] 06/29/12 15:17:50   15 = 0xE000FE23
[5136] 06/29/12 15:17:50   22 = 0xE000FE23
[5136] 06/29/12 15:17:50 ERROR: CreateBSD: Couldn't find \\exchangeserver.company.local\Microsoft Information Store\<+!RSG!+>
[5136] 06/29/12 15:17:50 startRestore: CreateBSD() failed!
[5136] 06/29/12 15:17:50 Restore Job Stop(10)  - Fri Jun 29 15:17:50 2012
[5136] 06/29/12 15:17:50 @@@@@@@MyCloseSocket called with sockfd = 2204(0x89c) retval = 0
[5136] 06/29/12 15:17:51 ERROR: ndmpdDataStop: invalid state to process stop request.
[5136] 06/29/12 15:17:51 @@@@@@@MyCloseSocket called with sockfd = 1748(0x6d4) retval = 0
[5136] 06/29/12 15:17:51 @@@@@@@MyCloseSocket called with sockfd = -1(0xffffffff) retval = -1
 
It looks the same as the problem in the knowledge base, except for the "<+!RSG!+>" thing, but due to restoring to the same server the situation explained in the kb doesn't apply..
 
This has been driving me nuts for several days, does anyone have any suggestions of getting one of these methods to work?

Comments 4 CommentsJump to latest comment

sazz.'s picture

Make sure you have all the rights on the account that you are using to restore on exchange as per

http://www.symantec.com/docs/TECH51740

 

Also make sure the system logon account is having the right credentials.

Twaf's picture

Thanks for your reply, the credentials are all set up as explained there (I'm just using the built-in administrator account for the active directory), it has a mailbox and is a member of the exchange admins and local admin on every system.

sazz.'s picture

Have it every worked?

What is the version of BE and Exchange. I guess BE 11d is only certified for Ex2007 SP1. Also do you have management console installed on the Backup Exec server

CraigV's picture

Twaf: In this case, your best bet is to upgrade to either BE 2010 R3 if you're still able to do so, or look at BE 2012 with SP1a. Take a look at BE 2012 though, as everything has changed about the way it works; most notably the GUI and the fact that backups are now server-centric (1 job per server) and not resource-centric anymore.

Trialware fo BE 2010 R3:

http://trialware.norton.com/files/fc/Backup_Exec_2010_13.0.5204_MultiPlatforms_Multilingual_DVD.iso

Trialware for BE 2012:

https://www4.symantec.com/Vrt/offer?a_id=91523

Take a look at the videos section here for more information on BE 2012. That said, if you have active maintenance in place, it's simply a case of mailing Symantec's licensing department and asking for new licenses (BE 2010 still uses license keys; BE 2012 has a licensing file with a .slf file extension).

IF you upgrade to BE 2010 R3, it's a straight-forward upgrade. Grab copies of the Data/Catalogs folders before doing so.

If you go to BE 2012, you need to upgrade to BE 2010 R3 and then to BE 2012. Don't forget the copy of the Data/Catalogs folders before any of the upgrades.

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

SOLUTION