Video Screencast Help

Restoring a Lenovo Laptop

Created: 16 Jan 2013 | 17 comments

I have a new Lenovo T430u that I am trying to backup using Symantec System Recovery (2010 at first and now trying 2013) to a external hard drive. I am then trying to restore this to another identical T430u so that I can save time configuring the laptop.

The back up goes fine and I don't notice any problems. I take all the default options and a few minutes later I'm set. I then boot the other laptop up using the SRD (tried 2010 and 2013 discs) and then I proceed to try and restore it. It claims to have successfully restore, but when I reboot the laptop I keep getting the Lenovo boot menu asking me where to boot from.

I thought maybe I made a bad backup so I tried a new one and no dice. Also tried changing the restore setting to use and not use the restore master boot record and original disc signature. Still didn't work...

Anyone had problems like this and if so do you know what could fix it?

Comments 17 CommentsJump to latest comment

Phil 777's picture

Do you know how to check to see which partition is set "active" - ie the bootable partition?

I haven't used any of the newest generation of Thinkpads yet, but historically IBM/Lenovo had proprietary "service" partitions pre-installed which were accessed using a custom bootloader that was activated with a button called "Access IBM", or later "ThinkVantage". It doesn't look like the T430u has that button though. (Probably has to do with the UEFI firmware)

They used to make a bootable disk that you could use to reset the MBR to point to the correct partition on boot, but that is probably all changed now with the UEFI architecture.

 

 

PravinAmin's picture

Hi Tony,

Can you please provide following information?

1. OS version you are backing up?

2. What type of partitiions you are backing up and restoring?

3. Is it the laptop in UEFI mode or in BIOS mode

 

-Thanks,

Pravin

Markus Koestler's picture

Did you set the options restore disk signatur and set partition as active for the boot partition ?

*** Please mark thread as solved if you consider this to have answered your question(s) ***

Tony 1776's picture

Hey guys, thanks for the responses.

I'm using Windows 7 64bit

Just backing up a single NTFS partition to another single partition. There is a tiny 24GB SSD but I'm not touching that at the time

The bios is set to use both UFEI and Legacy starting with UFEI, however I have tried forcing it to Legacy with no luck.

ok, just trying some more stuff out. It looks like the problem may be that for some reason the system reserved partition is not getting backed up... I'm going to try doing something a little different and see what happens. Any thoughts on why the system reserved partition isn't a option for backing up?

Markus Koestler's picture

Also try this restore order:

First the system reserverd partition, second the NTFS Partition. The reserved partition should be marked as active to allow boot from it.

*** Please mark thread as solved if you consider this to have answered your question(s) ***

Tony 1776's picture

I would love to do that, but for some reason the system partition isn't even showing up as a option to backup... Seems I have a different problem than I thought.

PravinAmin's picture

Hi Tony,

The System Reserved Partition should be shown as related drive in backup wizard. Another way would be to check the "Show hidden drives" checkbox on drives pages of Backup wizard.

From your comments above, I am not clear if the machine is in Legacy BIOS mode or in UEFI mode. If originally its in UEFI mode, there should be EFI System Partition (ESP). This can be verified in Diskmgmt.msc UI.

Based on whether the recovery point is of legacy BIOS or UEFI, restore target should also be same. In case of UEFI system restore, please make sure that the target disk type is GPT.

Restore order also need to be confirmed.

-Thanks,

Pravin

Tony 1776's picture

Thanks for the reply. There is a system reserved EFI partition in the disk management utility, so I'm assuming UEFI mode.. This partion isn't showing up in the backup utility whether I select the see hidden drives or not.

PravinAmin's picture

Hi Tony,

For restore to work, both EFI and C: needs to be backed-up and restored. I checked on Win7 x64 machine in UEFI mode and the EFI system partition is shown in related drives page whith SSR 2013 backup wizard. Please refer to attached screenshot.

To check further, can you please attach the screenshot of your diskmgmt snap-in?

 

-Thanks,

Pravin

RelatedDrives.JPG
Tony 1776's picture

Please see the two attached images.

I do have the boot partition, but Symantec System Recovery doesn't show the boot partition. If I choose to backup the C: drive it doesn't ask to backup related disks (on another computer it does).

Disks.PNG Backup.PNG
PravinAmin's picture

Hi Tony,

The only difference from my system is the pagefile, which is on separate disk in your configuration. I'll try to grab similar model laptop, however can you move the pagefile to C: from Advanced computer properties and check if it solves the issue?

 

-Thanks,

Pravin

Tony 1776's picture

Hmm I'll try that. Totally forgot I had moved it.

Tony 1776's picture

Didn't change anything. The page file is now on C: but System Recovery still doesn't see the hidden drive.

 

PravinAmin's picture

Hi Tony,

Can you execute partinfo.exe from C:\Program Files\Symantec\Symantec System Recovery\Utility folder? It'll generate partinfo.txt file. Please attach the file for investigation.

 

-Thanks,

Pravin

PravinAmin's picture

Hi Tony,

Thanks for sharing the partinfo. Can you also confirm the UEFI version on the laptop?

 

-Thanks,

Pravin

PravinAmin's picture

Hi Tony

Can you try following steps and see if the efi partition is listed in SSR:
1. Start Diskmgmt.msc
2. Right click on the disks which SSR is not able to see
3. Shrink the volume by some nominal size (1GB-5GB)
4. Stop "Symantec System Recovery" and "SymTrackService" services
5. Start "Symantec System Recovery" Service
6. Open SSR console and see if the volumes are enumerated.

-Thanks,
Pravin