Video Screencast Help

Restoring a vhd.

Created: 10 Jun 2013 • Updated: 13 Dec 2013 | 4 comments
This issue has been solved. See solution.

I have restored a vhd file that is the OS c:\ drive of a server. WHen starting this vhd file I get several "General Access Denied" errors and ther virtual machine fails to start.

Also I notice that the virtual machine size is considerably smaller than the original vhd file. Also it seems to have changed teh vhd from a fixed size to a dynamic size and I am unable to revert it back.

Has anyone else ran into errors like this when restoring a vhd file and trying to start the virtual machine?

We are using Backup Exec V-Ray 2012 edition

Thank you


Operating Systems:

Comments 4 CommentsJump to latest comment

Jaydeep S's picture

Changing the VHD from a fixed fize to dynamic seems to be a normal behaviour in case you are only restoring a single vhd. For this to work, you would need to have an identical VM setup ready and then import this vhd to the new machine. I am not sure if you are doing exactly this.

Additionally, If you are trying to achieve, cloning by doing this, it is a very lengthy and ineffective way. However, if the idea is to grab a few files from the restored vhd then the easier way would be to just mount the vhd in a test VM and grab what you need.

MLarouche's picture

Hi Jadeep

Forgive me but I am not quite sure I follow. Might be because I didnt explain it well too though. We lost the entire LUN that the virtual machine resided on so I had to recreate it and then tried to restore the full virtual machine backup which worked but when I go to start it through teh Virtual Machine Manager I get a "General Access Denied Error" like about 8 different ones.

So if I am to understand you correctly I need to basically build a new one start it then import the restored vhd file into this new running virtual machine?

thanks for the help Jadeep.


Jaydeep S's picture

Did try to restore the VM from BE without recreating it manually. Select the entire VM and restore it. If you want to restore with a different name, specify it in the VMware redirection tab.

For the access denied erros, reconfirm the permissions from the Vsphere client and make sure that they are as before.

Edit: Could you post a screenshot of the error that you get.

MLarouche's picture


I did try restoring the entire VM, but get the same error. Not quite sure whech permission is actually missing seeing how I have nothing to compare it too. This was in development and a power outage seemed to have blown away everything. Usually I could just remount the LUN and gain access to the drive no problem, not this time though, it wanted me to format the drive in order to use it, so I basically lost everything excep what is in my backups which are current (thank God) but I just cant seem to start them after restoring. I guess I could build a new one and see what the permissions are for it then go by that.

Seems like a big mess when I figured using hyper-v would be so much easier,,,,ugghhhhh

thanks Jadeep