Video Screencast Help

Restoring a VM to an alternative ESXi Host

Created: 22 Oct 2012 • Updated: 22 Oct 2012 | 7 comments

Hi i have recently began backing up my Virtual Environment with BE VMWare Agents. The backup runs fine and seems to work no problem i am happy with this. I have come to perform a test restore today and found that i can only restore back to the original host. AS you can imagine this is not ideal in a disaster situation.

I am using Backup Exec 2010 R3 with latest updates from LiveUpdate.

When i have tried to restore to the orignal host the process works perfectly and the machine is restored, as soon as i try to restore to another host in the same datacenter it fails with the error:

Restore- VMVCB::\\\VCGuestVm\Nottingham\vm\test intra VMVCB::\\\VCGuestVm\Nottingham\vm\test intraError writing file data.
V-79-57344-65072 - Connection to the restore target has been lost.  Operation canceled.
These are the settings i am using for the redirection, i am using the same account for redirection as restoring to the original so its not a permissions thing.
Further to this i have seen the stuff online about applying a hotfix if the machine you are restoring has 2 or more hard disks across different datastores.
Thsi machine has 1 Hard Disk on a single datastore and there is adequate space to accomadate it on the host.
If i look in the VCenter server i am trying to recover to i can see the following:

Comments 7 CommentsJump to latest comment

ZeRoC00L's picture

Do you have a license installed on the ESXi server you are restoring to ?

BE makes use of the Vmware vStorage APIs for Data Protection (VADP), this is only available if you have a licensed copy of ESXi.

If this response answers your concern, please mark it as a "solution"

ritchiescholten's picture

Yes everything is licensed correctly, i have just found this however which does not fill me with confidence!

ritchiescholten's picture

UPDATE: Tried with another VM this time a DC instead of a Sharepoint Server and the redirection process has worked, restored the VM to a host other than the original...

ZeRoC00L's picture

Just doublecheck if no ISI or Floppy is connected.

What is your ESX(i) and vCenter version anyway ?

If this response answers your concern, please mark it as a "solution"

ritchiescholten's picture

There are Floppy's but there are floppy's in all the VM's, even the ones that that have restored OK.

ESXi and VCenter Server 5.0.

it does appear to be just that one single machine, i have now restored 2 machines to alternate hosts and they have worked no problems.

For the time being i think the workaround is to use the VM Redirection to a folder option in the context menu of the backup job!