Video Screencast Help

Retrieving details of resource pools - Failed system call failed (11) with Alternate location Option (Netbackup 7.5.0.3)

Created: 06 Aug 2012 • Updated: 02 Apr 2014 | 4 comments
Phanuphan's picture
This issue has been solved. See solution.

Hello,

  I have got error " Retrieving details of resource pools - Failed system call failed (11) " after i had tried to recover virtual machine with Alternate location option.

 

 

 Here is the pertinent information and error details:

Client: Windows2008, NBU Client 7.5.0.3

Master server: Windows2008, NBU Server 7.5.0.3

Error detail of most recent failure:

16:44:27.735 [7452.8124] dovSphereLogin: sApiType = HostAgent
16:44:27.735 [7452.8124] dovSphereLogin: version = 4.1
16:44:27.735 [7452.8124] dovSphereLogin: sBuild = 348481
16:44:27.735 [7452.8124] dovSphereLogin: full name = VMware ESXi 4.1.0 build-348481
16:44:27.735 [7452.8124] dovSphereLogin: sName = VMware ESXi
16:44:27.735 [7452.8124] dovSphereLogin: sOsType = vmnix-x86
16:44:27.735 [7452.8124] dovSphereLogin: sProductLineId = embeddedEsx
16:44:27.735 [7452.8124] dovSphereLogin: sVersion = 4.1.0
16:44:27.735 [7452.8124] dovSphereLogin: sServerCurrentTime = Mon Aug 06 16:44:31 2012

16:44:27.735 [7452.8124] dovSphereLogin: login for ESXHQ-01.CDGM.LOCAL completed with flags 70 and status 0
16:44:29.061 [7452.8124] vmwareLogger: RetrieveObjPropertiesEx: for mor = Null failed, SYM_VMC_ERROR:  SOAP_ERROR

16:44:29.061 [7452.8124] vmwareLogger: SOAP 1.1 fault: "":ServerFaultCode [no subcode]
"The object has already been deleted or has not been completely created"
Detail: <ManagedObjectNotFoundFault xmlns="urn:vim25" xsi:type="ManagedObjectNotFound"><obj type="HostSystem">Null</obj></ManagedObjectNotFoundFault>

16:44:29.061 [7452.8124] vmwareLogger: getObjectProperty: Could not get property summary for, mor=<Null><HostSystem>

16:44:29.061 [7452.8124] vmwareLogger: RetrieveDcMorAndObjMorFromPath: SYM_VMC_ERROR:  FAILED_TO_GET_OBJECT_PROPERTY

16:44:29.061 [7452.8124] vmwareLogger: GetConfigTargetNetworkDetailsAPI: SYM_VMC_ERROR:  FAILED_TO_GET_OBJECT_PROPERTY

16:44:29.061 [7452.8124] vmcGetConfigTargetNetworkDetails failed for ESXHQ-01.CDGM.LOCAL with 74
16:44:30.356 [7452.8124] vmwareLogger: RetrieveObjPropertiesEx: for mor = Null failed, SYM_VMC_ERROR:  SOAP_ERROR

16:44:30.356 [7452.8124] vmwareLogger: SOAP 1.1 fault: "":ServerFaultCode [no subcode]
"The object has already been deleted or has not been completely created"
Detail: <ManagedObjectNotFoundFault xmlns="urn:vim25" xsi:type="ManagedObjectNotFound"><obj type="HostSystem">Null</obj></ManagedObjectNotFoundFault>

16:44:30.356 [7452.8124] vmwareLogger: getObjectProperty: Could not get property summary for, mor=<Null><HostSystem>

16:44:30.356 [7452.8124] vmwareLogger: RetrieveDcMorAndObjMorFromPath: SYM_VMC_ERROR:  FAILED_TO_GET_OBJECT_PROPERTY

16:44:30.356 [7452.8124] vmwareLogger: GetConfigTargetDvPortGroupDetailsAPI: SYM_VMC_ERROR:  FAILED_TO_GET_OBJECT_PROPERTY

16:44:30.356 [7452.8124] vmcGetConfigTargetDvPortGroupDetails failed for ESXHQ-01.CDGM.LOCAL with 74
16:44:30.356 [7452.8124] generateServerFiles: listNetworks failed with 11
16:44:30.356 [7452.8124] dovSphereDisconnect: disconnect for ESXHQ-01.CDGM.LOCAL completed with flags 0 and status 0
16:44:30.356 [7452.8124] <2> browseDatastores:  generateServerFiles returned 11
16:44:30.356 [7452.8124] <2> bpVMutil main: EXIT STATUS 0: the requested operation was successfully completed
16:44:33.498 [1100.6816] <2> logparams: C:\Program Files\Veritas\NetBackup\bin\bpVMutil.exe 5632 ESXHQ-01.CDGM.LOCAL ESXHQ-01.CDGM.LOCAL
16:44:33.498 [1100.6816] virt_test_log: log function is called
16:44:33.498 [1100.6816] <2> bpVMutil main: cmd = 22 ESXMount = ESXHQ-01.CDGM.LOCAL ESXserver = ESXHQ-01.CDGM.LOCAL, flags = 0
16:44:33.498 [1100.6816] generateServerFiles: get_id_lock returned 0:  -> wait lock timeout value: 15 minutes -> WRITE LOCK ESXHQ-01.CDGM.LOCAL_lock fd = 248 -> lockname = ESXHQ-01.CDGM.LOCAL_lock
16:44:33.498 [1100.6816] generateServerFiles: checking file C:\Program Files\Veritas\NetBackup\online_util\fi_cntl\ESXHQ-01.CDGM.LOCAL_datas_tree.xml
16:44:33.498 [1100.6816] generateServerFiles: checking file C:\Program Files\Veritas\NetBackup\online_util\fi_cntl\ESXHQ-01.CDGM.LOCAL_net_tree.xml
16:44:33.498 [1100.6816] <2> browseDatastoreTree: get_id_lock returned 0:  -> wait lock timeout value: 30 minutes -> WRITE LOCK ESXHQ-01.CDGM.LOCAL_lock fd = 248 -> lockname = ESXHQ-01.CDGM.LOCAL_lock
16:44:33.498 [1100.6816] <2> browseDatastoreTree: fileCOPY of C:\Program Files\Veritas\NetBackup\online_util\fi_cntl\ESXHQ-01.CDGM.LOCAL_datas_tree.xml to C:\Windows\TEMP\VMutl-01100344246273498816000000000-a06816 returned 0
16:44:33.498 [1100.6816] <2> bpVMutil main: EXIT STATUS 0: the requested operation was successfully completed

 

What steps should I take to get this done? and suggest me the best.

Thanks in Advance

Phanuphan

 

 

Comments 4 CommentsJump to latest comment

VanilaSphere's picture

It seems ok as NBU can login to ESX server.

 

16:44:27.735 [7452.8124] dovSphereLogin: login for ESXHQ-01.CDGM.LOCAL completed with flags 70 and status 0

 

but I don't get this error.

 

 

16:44:29.061 [7452.8124] vmwareLogger: RetrieveObjPropertiesEx: for mor = Null failed, SYM_VMC_ERROR:  SOAP_ERROR

16:44:29.061 [7452.8124] vmwareLogger: SOAP 1.1 fault: "":ServerFaultCode [no subcode]
"The object has already been deleted or has not been completely created"
Detail: <ManagedObjectNotFoundFault xmlns="urn:vim25" xsi:type="ManagedObjectNotFound"><obj type="HostSystem">Null</obj></ManagedObjectNotFoundFault>

16:44:29.061 [7452.8124] vmwareLogger: getObjectProperty: Could not get property summary for, mor=<Null><HostSystem>

16:44:29.061 [7452.8124] vmwareLogger: RetrieveDcMorAndObjMorFromPath: SYM_VMC_ERROR:  FAILED_TO_GET_OBJECT_PROPERTY

16:44:29.061 [7452.8124] vmwareLogger: GetConfigTargetNetworkDetailsAPI: SYM_VMC_ERROR:  FAILED_TO_GET_OBJECT_PROPERTY

 

I suspect this message "The object has already been deleted or has not been completely created".

 

I tried google it and there is something relate to snapshot.

you can try this link:

http://www.symantec.com/business/support/index?page=content&pmv=print&impressions=&viewlocale=&id=TECH186919

SOLUTION
Wiriadi Wangsa's picture

I had exactly the same error after choosing "Alternate location" and "Next >"

Looks like it fails when probing the Resource Pool/vApp.

NetBackup version 7.5.0.1, ESXi 5.