Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Return code: 30066 with Microsoft office 2010 package

Created: 06 Feb 2013 | 10 comments

I created a office 2010 package, and try to send to users, it was working on my old server which is NS7.0 server for while, now I have new NS7.1 server, so I moved all the users to new server, then I copy the package from old server to new server.

here the command prompt like this:

"\\altirisserver\NSCap\bin\win32\x86\_City of Glendale Repackaging\Office 2010 Resource\setup.exe" /config "\\altirisserver\NSCap\bin\Win32\X86\_City of Glendale Repackaging\Office 2010 Resource\ProPlus.WW\config.xml"

if I take this line manually run from the workstation, it work just fine.

if I use NS send this package out then it gave me return code: 30066, when the job start running, it show in progressing for a while then die.

I do use domain account send the package out.

Thanks

Lillian

Comments 10 CommentsJump to latest comment

andykn101's picture

30066 is PreReqCheckFailure, for example disk space or maybe it's an XP PC that dosn't have SP3.

There should be an Office setup log file in a temp directory with more info.

I wouldn't install from a network share either, the whole point of a tool like Altiris is that you can create a package and manage it through Altiris. If you are using NS defaults it will be trying to access the share using the built in local system account that doesn't usually have access to netwotk shares - only reesources on the PC.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

llian's picture

WOW, this the true, this machine only have SP2, I will upgrade to XP3 and give a try

Thanks

Lillian

andykn101's picture

Do what I did, go to Settings > Software > Software Catalog... > Installation Error code descriptions and add 30066. It'll show up on the Software Execution Report (you do run that at least weekly, don't you?) and at least serve as a reminder of what the error code means. It's how I looked it up.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

llian's picture

Andykn101,

Guest what is working now, after I upgrade to XP3, my package was successfully installed, thanks for the hint.

Have a good day

Lillian

llian's picture

Andykn101,

Please see the attchment, is this what you talking about with error code?

Thanks

Lillian

Error code_02_06_13.gif
andykn101's picture

No, you can't put a description in there and, because it's not in the success code list 30066 will always be interpreted as a failure.

You can put it here: Settings > Software > Software Catalog... > Installation Error code descriptions with a description and the description will show in the Software Execution Report. You should run that report at least weekly to see what software deliveries are failing.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

llian's picture

Andykn101,

Ok, I found the place, can you verify for me?

Thanks for all the help

Lillian

Error code_02_06_13.gif
andykn101's picture

I don't know if you put the wrong screenshot in but that's the same one you put last time and isn't the right place, my last answer still applies.

Also it's best to put the install files in a package and not install over the network and the install file type should be set too - it may not have an obvious effect but not doing could cause you problems later.

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.

llian's picture

Andykn101,

Sorry I did the wrong attachment, here is the correct one

Thanks
Lillian

Return code_30066_02_07_13.gif
andykn101's picture

That's the right place but you need to select the correct "Installation File Type" (probably an EXE for Office 2010) or  it won't show correctly in the Software Execution Report.

And you might want to make the description a bit more general, next time you get the error it might be lack of disk space (especially on a VM).

Authorised Symantec Consultant (ASC) with Endpoint Management Limited, an Authorised Symantec Delivery Provider based in the UK.

Connect Etiquette: Please "Mark as Solution" posts that fix your problem.