Video Screencast Help

Reverse DNS does not match SMTP Banner - Messaging Gateway

Created: 02 Sep 2011 • Updated: 04 Oct 2011 | 6 comments
lukassc's picture
This issue has been solved. See solution.

 Hi everyone, I had a problem with Messaging Gateway. When I run the SMTP scanner on mxtoolbox.com this result came up.

OK - 190.12.x.x resolves to mx.xxxx.com.ar
 Warning - Reverse DNS does not match SMTP Banner
 0 seconds - Good on Connection time
 Not an open relay.
1.123 seconds - Good on Transaction time
 

What can I do from Messaging Gateway to solve this situation?

THX to all.

Comments 6 CommentsJump to latest comment

MxToolBox's picture

Thanks for using our Diagnostics Tool. This warning can mean one of two things!

1) Your SMTP Banner and rDNS record do not match. In a perfect world these would match and/or resolve to the same Fully Qualified Domain Name (FQDN). More Details

2) Your SMTP Banner is Masked. More Details

Again, thanks for using our tools. We are constantly working to make them bigger and better all for free!

@mxtoolbox

pbaggiol's picture

You can customize your banner (a.k.a SMTP Greeting) on the "Protocols -> SMTP -> Settings" page.

This may help remove this warning if its important to you.

lukassc's picture

I have change the SMTP Greeting with mx.xxxx.com.ar but we are still having this problem.

The following image is the section were the change was made.

TSE-JDavis's picture

You haven't shown us the full report, so it is hard to say what the issue is. Please see this screen shot of a random test I ran:

 

mxtoolbox.PNG
TSE-JDavis's picture

You have a Cisco firewall with mailguard turned on. This masks your SMTP banner with *********, which does not match mx.soporteconectar.com.ar.

SOLUTION