Video Screencast Help

Robotic library and using one tape per server / job

Created: 10 Aug 2012 | 1 comment

I upgraded two days ago from 2010 R2 to the 2012 (sp1a).

Here are the result of the upgrade that make me an unhappy camper of 2012 release:

1 - one of my jobs that existed in 2010 was not converted.  It is gone. No where to be found.  The history of the job is there but no sheduled job.

2 - cleaning tape job that was scheduled was converted, but is now hidden under storage for some reason

3 - The conversion of the job in 2010 is now split into servers but they are gouped under one name or job.  Now when the job runs, each server (8 servers) writes to a new tape when the job runs.  So now I am wrtiing to 8 individual tapes.  Previously, the job in 2010 would write to one tape for all the servers.  If that taped filled up, then the next available tape would be written to.  I know this is not most effecient backup process, but this has worked for us for many years.

In 2010, I had tapes held for 8 days befrore they could be written to again. So with the 2012 job, 8 tapes from last night back up will not become avail for 8 days,  This is will not work.

I have seen discussion on the append media selection, but after talking to support (ticket #600825918) they could not confirm that the append jobs would all write to the same tape and that I would need to partition all the slots in the library to make the server job pick the same tape for back up.  If I have to partition the slots, I will go back to 2010 and see if the next release will correct this issue.

If teir 2 support cannot repond back to me, I guess I will be changing the server jobs to append the media.

I will also mention I have phantom jobs kicking off from time to time.  I thought maybe I was just over zealous with clicking on things but as I was doing a screen share meeting with the tech, a test job (i created the day before with no schedule) kicked off without me or him doing anything.  Very strange.  Support rep had no explanation for it either.

-b  

Comments 1 CommentJump to latest comment

pkh's picture

2 - cleaning tape job that was scheduled was converted, but is now hidden under storage for some reason

This is the way BE 2012 is designed.  All utility jobs, like inventory, catalog, etc. are now listed under the storage device.

For your append problem, you don't have to use partitions.  This does not help.  Presumably you are doing daily jobs.  What you need to do is to set the appropriate AP in your tape media set.  For example, set your AP to 23 hours.  This will allow all your daily jobs to append to the tape.  Your first daily job will specify overwrite and all the rest of the daily jobs will specify append.  The 23 hours of append time will allow all the jobs to append to the tape that is overwritten by the first job.  On the following day, this tape is no longer appendable.  So for each day, the only appendable tape is the one that is just overwritten by the first daily jbo.  This way you can be assured that only one tape is used daily.  This presumes that the data from all your daily job can fit into one tape.