Video Screencast Help

RSM cannot manage library Tape2. The database is corrupt error in Alerts

Created: 18 Apr 2007 • Updated: 21 May 2010 | 20 comments
This issue has been solved. See solution.
Ever since upgrading from 10d to 11d we receive about 800 alerts every time the Backup exec services are rebooted.  The version of 11d we are using is rev6235, with hotfixes 6, 9, 10, 11, 13, 15 and 16 installed.
Here is a sample of the alerts:

RSM cannot manage library Tape0. The database is corrupt.

RSM cannot manage library Tape1. The database is corrupt.

RSM cannot manage library Tape2. The database is corrupt.

The device, \Device\Scsi\adpu160m1, is not ready for access yet.

The backups and restores work fine and we do not experience any hardware related issues.

Any ideas on how to fix this problem? Thanks

Comments 20 CommentsJump to latest comment

Patty McGowan's picture
Ivan,
 
This will occur if you are running Backup Exec and you have Removable Storage running. Backup Exec has control of the tape device and RSM is attempting to do the same.
 
If you stop and disable Removable Storage in the services panel you will not see this error again.
 
Patty
Ivan P's picture
The removable storage service is stopped and disabled already. Any other ideas?
Patty McGowan's picture
RSM is putting off that error.
I would say to search for that task in task manager to see if it is running even though it is showing stopped.
 
Do you have any other applications running on this server?
 
Patty
Ivan P's picture
The task is not running. There is nothing else running on this server.
The server has been rebooted several times.
Patty McGowan's picture
Ivan,
 
That is very strange.
 
How often are you getting these errors? 
 
Patty
Ivan P's picture
Every time we restart the Backup Exec  services or reboot. The backups and tape drives work fine.
Patty McGowan's picture
Ivan,
 
Something appears to be trying to start RSM.
The errors are fine as long as your drives are working.
I would look to the MS knowledge base to find out why the service is trying to control a device when the service is stopped.
 
Patty
squire07's picture
We've just started receiving this errors with BE11d. Has there been a more defined resolve to this issue other than Pam's last response?
SteveVRTS's picture

Can you please copy and paste the error from the event viewer.  When I say copy, I don't mean highlight the text and paste it.  I mean open the event up in event viewer and click on the button right below the up and down arrows.  That will copy it and then just paste it here.

takuan39's picture
Hello -
 
I am getting the same error as well.  I had a Win2000 server with a Dell PowerVault 124T, running fine with Backup Exec v10.  I moved the SCSI card and library to a Win2003 server and installed Backup Exec 11d, latest hofixes, and latest drivers (as of today).  Microsoft Device Manager sees both library robotics and single tape drive.  RSM was disabled and server rebooted before BE installation.  BE Device Configuration Wizard configures the library drive as a stand alone.  When i go to Configure Tape Library Drives, i get the above error, that RSM cannot manage Changer0. Database is corrupt.
 
I tried the idea of stopping RSM, removing old database, and starting RSM, no luck.  I tried the regedit idea as well, no luck.
 
Any ideas?
 
Thank you !
edc99801's picture

I'm also getting the same message. The server in question is running Windows 2003 R2 and has two tape drives, an LTO2 and a DAT. My plan was to use Backup Exec 11d to take encrypted backups on the LTO2. I had hoped to continue using ntbackup to backup daily changed files to the DAT. Apparently I cannot do that, or can't figure how at this point. Does installing Backup Exec mean that ntbackup will no longer work with any of my tape drives?

BEsymc's picture

Hi All,

Please try following document:
http://support.veritas.com/docs/300454

If this does not fix, suggest contacting MS in order to repair RSM database or go through following MS document:
http://support.microsoft.com/?id=235032

Thanks

Colin Weaver's picture

Looks like Backup Exec polls the event logs on service start and records the RSM error if it finds it in the event logs, it should only report each error the first time it finds it, however it appears that environmental conditions on some servers cause the error to be detected every time - even if you have disabled RSM so stopped new errors from being generated.

Solution is therefore clear out your System and Application event logs (save them if you need them for tracking purposes)

SOLUTION
eduzav's picture

I have the same issue, so the conclussion is to disable the rsm service???

Colin Weaver's picture

RSM is not supported with current versions of Backup Exec so this must be disabled anyway.

The solution to the issue itself is Clear your event logs (after disabling RSM)