Video Screencast Help

rtmp stream not working

Created: 31 Oct 2012 • Updated: 31 Oct 2012 | 5 comments


we have a problem displaying a rtmp live stream. I even made a policy that allows everything but the stream is still not working.
It's currently only a demo page to check the stream ( It seems like a flv file is loaded using rtmp.

Using an alternative proxy the stream works fine.

Is there any way to show this content? The swg is running in proxy mode, the version is


Discussion Filed Under:

Comments 5 CommentsJump to latest comment

BenDC's picture

Is the page blocked or an error?

If you run a custom report for the workstation IP address that is accessing the page is anything show that it was blocked?

It may be necessary to bypass the proxy using an proxy exception for that domain/site depending on how the webserver provides the content.

jvrieze's picture

no error, page is not blocked. The swf that is playing this stream just keeps loading.
In the custom report also nothing is blocked.

today i see the stream loading for about 5 minutes and then it starts. Using another proxy to connect it starts in about 5 seconds.

SMLatCST's picture

It sounds as if the SWG is caching this file as a download instead of letting it through as a stream.  What's the size of the file?  Have you tried lowering the "Maximum Cache Object Size" value in Configuration -> Proxy?

jvrieze's picture

The maximum cache size is 256kbytes. I don't know the size of the file, it seems not very large to me.

The given stream is a test stream and contains a repeated video, i think the video may be around 10MB.This evening wil be a live stream that wil run for an hour. I hope this stream will be cached before it starts.

I tried to add cache exceptions for this stream, but that also doesn't seem to help.

jvrieze's picture

this problem is a little weird.

Using IE8, it takes about 5 minutes to load. Using another proxy it starts almost instantly.
Using google chrome it starts instantly, no matter wich proxy server I use.