Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

RU6 - SEP Install Failed - PendingFileRenameOperations

Created: 06 May 2010 • Updated: 08 Jun 2010 | 5 comments
This issue has been solved. See solution.

Hi All,

So, I have a client running Windows 2003 Server and when I try to install RU6, I am getting this error in the event logs:

Event Type:    Error
Event Source:    MsiInstaller
Event Category:    None
Event ID:    10005
Date:        5/6/2010
Time:        7:01:01 AM
Description:
Product: Symantec Endpoint Protection -- Symantec Endpoint Protection has detected that there are pending system changes that require a reboot.  Please reboot the system and rerun the installation.

I have deleted the PendingFileRenameOperations value in the registry, (HKLM>System>CurrentControlSet/XXX>Session Manager), but am still getting the error above. Any ideas? Thanks!

Mike

Comments 5 CommentsJump to latest comment

P_K_'s picture

From the kb
Title: 'Symantec Endpoint Protection (SEP) 11 client installation fails with the message "Pending system changes that require a reboot have been detected"'
Document ID: 2007121609023348
> Web URL: http://service1.symantec.com/support/ent-security....

Follow

If HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update\RebootRequired exists, right-click on the RebootRequired registry key and choose Export.
Provide a different file name than in step 4 for the exported registry key and click Save
Delete RebootRequired sub-key
Install Symantec Endpoint Protection normally
Before rebooting, double-click on the .reg files created in Step 4  and 7 to merge the previous PendingFileRenameOperations value and RebootRequired sub-key

MCT MCSE-2012 Symantec Technical Specialist (SCTS)

postechgeek's picture

I think I missed the reboot required key. Cool, thanks. I'll give this a shot this afternooon. I appericate it.

Thanks,
Mike

postechgeek's picture

Here is an interesting tidbit. The above seems to work, however after the install with the new RU6 install package, the client is still showing the old client version of RU5. Has anyone else seen this? Strange, I double-checked to make sure I was using the new install package as well.

Mike

SOLUTION
P_K_'s picture

That is really strange,
Can you please uninstall and Install SEP RU6 and lets see how does it works

MCT MCSE-2012 Symantec Technical Specialist (SCTS)

postechgeek's picture

@ Prachand,

That did the trick. Uninstalling and reinstalling. Thanks!

Mike